Printing xlsm files

When printing xlsm files, the pdf file name adds the “m” of xlsm at the end of the original file name. Can I correct this ? This problem does not occur with xslx files.

I also have had this problem since getting Office 2010.

.xlsm files are the new format of Excel files that are saved with a macro.

It would be good if this was fixed in future updates.


I use the german version, so I do not know the right english terms.
Take a look at setting. There in the section “save” you will find “filename replacements”, where you can add xlsm.
Maybe that will help.


as bb_dn pointed out this is due to filename substitutions, “xls” and “xlsx” are set to be substituted with blank by default, so you simply need to add a substitution for xlsm to blank.