Problem with Vista UAC

I installed PDF Creator 0.9.8 on Vista Business SP2 (UAC enabled). After that, i tried to make PDF from notepad. PDF Spooler allways turned me back to Save AS dialog - Overwrite - Save As - Overwrite - Save As.... I discovered in Options - Directories that Temporary files are stored in C:\\Program Files\\PDFCreator\\Temp\\ were Vista don't permit deletnig even user is administrator. Then I click "Reset all Settings" and "Save". With PDF Print Monitor opened I check to see that changes were saved to PDFCreator\\. Then I was able to finish Save As function finaly and clear temporary files from the Spooler directory. I checked even in Registry in HKCU\\Software\\PDFCreator\\Program that "PrinterTemppath" shows to the righ place (C:\\Users\\username\\AppData\\Local\\Temp\\PDFCreator\\). 
After that, I closed PDF Print Monitor. Next time, when I tried to make another PDF document with PDF Creator, same thing happened and I discovered that location for the Temporary files are turned back to C:\\Program Files\\PDFCreator\\Temp\\. This happens allways when I start PDF Creator from the Programs or invoking from Print.
Then I tried to change in Registry HKLM\\Software\\PDFCreator\\Program value for "PrinterTemppath" to show the desired folder (for example c:\\temp), restart the computer and PDF Creator, but without result that I expected. The Temporary files again showing C:\\Program Files\\PDFCreator\\Temp\\.
Only thing that helped me to resolve this issue was disabling UAC. After disabling UAC, things start working as expected. Inserting the values in HKLM\\Software\\PDFCreator\\Program for the "PrinterTemppath" I was able to force setting over the user settings. After enabling UAC, issue starts from the beginning.
Disabling UAC is really something that I won't to do in production, so I kindly ask if there is some other way wich can be applyed throug GP (or some other metod) in enterprise and solve this problem with UAC enabled.
I also found other workaround (giving the Change right for the \\\\Computername\\Users group to the C:\\Program Files\\PDFCreator\\Temp\\ folder) but it is also somethihg that I don't recomend.

Hello, you have two other alternatives, not respectfull with standard Vista installation but they work.

1) the worst : Change properties of pdfcreator to allow him to run as administrator. Not secure in enterprise.


2) install pdfcreator out of program files , directitly under root drive.

Sorry for my fluent english. I hope you will find a better solution.

Thank you titou_24 for your advices.

I'am thinking about applying second sugestion but there are some other thing that I need to investigate prior to deploying.

I have the same problem. My changes in the settings are not saved.

I want to disable autosave, but no way I can do it.

If other programs make "ini" files for PdfCreator, where would they be stored?

I ask this question, because I manually deleted the lines with autosave in the Register of Windows 7, but all the lines were restored with the "old" folder paths etc. I don't understand where that information came from. I'm running 0.9.9 but I had the problem with 0.9.8 too.

Bonne journée