Problems by installing PDFCreator on Windows 10


when I installing PDF Creator 4.4.1 and 4.4.3, I have the problem that on some
computers the PDFCreator printer cannot be installed. We have the function update 21H2 on all Windows 10 computers. On the computers is the same Hardaware and Software.
We have already tried the following things on the computers where it does not work:

Uninstall and reinstall
Virus scanner disabled
Tried different Windows users (also with local administration rights)
Different versions of PDF Creator

The setup routine always says everything was installed successfully, but when you click on the PDF Creaqtor desktop shortcut it says there is a problem and needs to fix it! The Repair-Function doesn't work either! No PDF Creator printer has been created under Windows!

Is there a way to perform a "clean" deinstallation? So I can cleaning of the Windows registry or how can I manage to install the program correctly? As already mentioned, I have other identical computers where it works!
I would be very grateful for a solution.

Did you tried this?

No printers installed


Finally fixed it. Running it in commandline revealed the same issue of “Unhandled Exception: System.UnauthorizedAccessException: Access to the path ‘C:\WINDOWS\system32\spool\DRIVERS\x64\PS_SCHM.GDL’ is denied.”

So I just enabled all permissions for that file. First you have to make yourself the “Owner” : Right Click, Properties, Security tab, “Advanced” button", at the top there is “Owner:”, click “Change” to the right of that, find your user and set it. Then press OK all the way out. Come back into Properties/Security, Edit permissions, give everyone full control. Then reinstall the printer (commandline or GUI attempt from PDFCreator).