Proper page rotation goes away in combined document

I'm using Version 1.6.2 of PDF Creator on a Windows 8 laptop in Excel as part of Office 365 Home Premium.

When I use:
     Workbooks().Printout copies:=1, ActivePrinter:="PDFCreator"
I get a multi-page PDF file with new pages starting for each of the sheets in the workbook. The pages correctly maintain the orientation as specified by each sheet's printing orientation, in which some are landscape and some are portrait. It's beautiful.

However, when I use this exact same code between print outs of portrait-oriented pages, and then use .cCombineAll, all the pages in the document go portrait, including the ones that correctly printed landscape when in their own document. It's ugly.

This would be a work-around: Is there a setting for programmatic control of PDFCreator that will specify the orientation for each print job before combining? I've read that AutoRotate doesn't work. But if there were a controlled setting that worked, I could break the Excel workbook with multiple pages into different print jobs for each orientation. If this functionality isn't there, it's definitely expected to be there, and needed.

From the previous discussions, this appears to be a PDFCreator bug, or at least an issue for which a public work-around has not been found. What's different in my experience, which I haven't seen discussed elsewhere, is that one document -- such as one spreadsheet with multiple sheets -- can have both orientations in it.

I see there's a similar thread, "[Combined documents] page rotation issue", but since it is full of lengthy repeated error messages, and I am presenting here a potential workaround for some situations, I'm starting a new thread.

Follow-up... When I installed the same code on a Windows 7 desktop using Excel 2013 it worked perfectly! The landscape pages were landscape, the portrait pages were portrait.

Another difference was that I was careful to only install PDFCreator, skipping PDFArchitect and GhostScript. I won't be able to test this on my Windows 8 machine for a couple of weeks.

Since Windows 7 is the run-time environment, this is resolved for me.

Note that there's some kind of bug going on with Windows 8, or the interaction with the 3 products.

This has now been confirmed as a bug when run in Windows 8.

On my Windows 8 laptop, I uninstalled PDF Creator and PDF Architect. There was no listing in Programs and Features for GhostScript. I then re-installed PDF Creator, skipping PDF Architect. The option for GhostScript 9.05 was grayed out, so I no choice but to install it as well. The problem persisted with landscape pages being printed portrait.

One point of difference is that I was able to do the install on the Windows 7 machine without GhostScript. So it possible, but probably unlikely, that an original install on a Windows 8 machine without GhostScript -- if that can be done -- would solve the issue.


you can´t run PDFCreator without Ghostscript, if it was optional to opt out on windows 7 then only because you allready had Ghostscript installed somewhere on your system. Maybe it was a different version, you could additionally install that version on Windows 8 and make PDFCreator use it instead of 9.05.



I would like to confirm that this has been fixed in Version 1.7.0.