There was an error installing one or more printers

As the title states, I am doing a command line install and I get this error.
I click OK on the error, it goes away. I run the install a second time and it installs.

report from the log file before and after failure:

No previous version detected, attempting to install printers
There was an error installing one or more printers
InstallPrinter Action ended
CustomAction InstallPrinter returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 11:30:08: InstallFinalize. Return value 3.
SFXCA: Extracting custom action to temporary directory: C:\WINDOWS\Installer\MSI6833.tmp-
SFXCA: Binding to CLR version v4.0.30319
Calling custom action PDFCreator_setup!pdfforge.PDFCreator.Setup.Builder.Features.PDFCreatorFeatureBuilder.UninstallPrinter

Now for a little backstory. I am trying to configure this for Microsoft's Intune. We have three versions of this software: English, French, German. From what i was told, we need to write a registry key per the location on what the language is going to be.
So for intune, i have a batch file that runs the MSI as such: msiexec.exe /i "PDFCreator-Business-3_4_1_18620-Setup_x64.msi" LicenseKey="licensekey" /quiet /passive and then after that, it calls a powershell script that writes to the directory for which language the install is.

When i run the install the first time, i get the error code. I click ok, it backs out and then i run the install again and it works. What needs to be done to get this to install on the first try without that error.

since support doesn't address all of the posts in the forums. is there a number or email i can use to contact them directly? I dont want to be like that guy that has waited 20 days without a single response.


sorry for the long delay, this Forum is mainly intended as a user helping users platform,
please generally use the contact form on for a faster response.
Are you still getting this issue in PDFCreator 3.5.1?
I am not able to reproduce it without additional information, installing with the parameters you specified works without issues here. You can add /L*V log.txt to the parameters to get detailed logging.
Might there be remainders of previous PDFCreator versions on the system?
I assume Intune runs with full admin permissions?

Best regards


yeah. i will try adding the logging file. Yes, Intune runs with full admin unless you tell it to run at a user level.