Unable to connect to internet

I have tried everything I can think of to get PDF Architect to work on my computer but it continually says it's unable to connect to internet. I can log into my account but when I try to enable the merge function is gives me this error.

Hi Revilo,

Do you think PDF Architect tries to download a missing module, but is unable to do so?

Kind regards

Hi Sascha,
That is exactly what it acts like.
I go into Create/Merge files. Then it asks for a login which I type in but doesn't work although I can login to that account on the site.

It then replys with the error that no internet connection exists, yet it does.
Any help would be appreciated. I've also tried using the Microsoft account login with the same effect in the app. Again it works online though??
This is so frustrating!

Had the same issue. Apparently you´ll have to include both those domains in your firewall/antivirus white list:

(just change "#" for ".")

I am at an absolute loss. The software worked perfectly in the free version now is a problem on the paid version. "NO INTERNET SIGNAL" unable to login. Absolutely no response from support - staring to think I have wasted my money here

Any ideas for a workaround

I had the same issue and believe it started after I upgraded to Windows 11. As mentioned earlier, it was a firewall issue. Even though PDF Architect was listed as a trusted application, I added it to the exclusions in my antivirus, restarted, and it cleared up.