Unable to open pdf

Hi All

Newbie to this forum so if I happen to do the wrong thing feel free to let me know.

I have used Creator for at least the last two years and love it as it uses nice large screens and i like the logical way that it goes from save to a print option.

That was until last week when i clicked on an existing PDF and all i got was a few seconds of the wheel of death then back to pointer - nothing opened!
I have Architect loaded on a Vista platform. Have just tried another download with no changes.
Any assistance would be appreciated


in rare cases there is a problem with PDF Architect which doesn´t get solved by reinstalling, you can try the following steps to solve it:

1. Authorize in Windows account as administrator.
2. Check if the Windows Automated updates function is enabled and all the updates are installed. Ensure that there is no msiexec.exe process in the list of running processes. If it is on the list restart OS.
3. Close all the windows and applications.
4. Uninstall PDF Architect
5. Install PDF Architect again. At the last step of installation uncheck the option "Run application"
6. Go to Start -> Run-> services.msc /s
7. Make sure that services “PDF Architect Helper Service” and “PDF Architect Service” are started. If not then start them.
8. Run PDF Architect. If you have slow processor and/or there is few RAM, then wait couple of seconds for application to start.