Unwanted notations in CAD drawings

Several months ago I did an update and since that time when I view CAD drawings I've created with PDF Architect I get the text I've typed and also a yellow symbol which contains the same text I typed. This is very annoying and wasn't there before I did the update. I have tried emailing you directly and haven't gotten a response. I need to get this fixed.


did you perhaps previously add text-boxes, while you are now adding annotations?
Or did you always use annotations, but the way they are displayed has changed?
If you add text boxes there shouldn't be any yellow symbol next to them.

Best regards


I use multiline text which is also used when creating associative leader objects, which I've been using for years. This has only been happening for a few months, since I did an update.

Sorry for the trouble, which version of PDF Architect do you currently have installed?
Are you using the "Type Text" functionality from the "Edit" module
or a different tool/module?

I'm not using PDF Architect to create these objects, These are coming from my AutoCad drawing. I create the drawing and print it to a pdf using PDF Architect.

Ah ok, now I understand. Did you update PDF Architect or the CAD software?
If those symbols are actually sent to the (virtual) printer, there won't be anything we can do about it.
If PDF Architect for some reason adds these by itself, we can look into it.
Do you by any chance also have PDFCreator installed (our virtual printer)?
If yes, do you also get those additional symbols when printing to PDFCreator?
Alternatively, you could use the inbuilt Microsoft PDF printer if you are on Win 10, or the XPS document writer on earlier Windows versions, to check if the symbols are created by the CAD software or not.

I don't have PDF Creator installed and I'm using PDF Architect 5 Professional edition. I was using and had been using Civil 3d 2017 for a while and did an update on PDF Architect when it happened. I've since gone to Civil 3d 2019 and still have the same problem.
I used the built in pdf printer and when the drawing opened (in PDF Architect) the symbols were still there, so I opened it with Adobe PDF reader and the symbols are not there.
Looks like a PDF Architect induced issue.

Thanks for the feedback, sounds like it is an issue with how PDF Architect displays the file, I will check if there is any setting to disable it or if it is an actual bug. Could you kindly send one of the files displaying hte issue to support(at)pdfforge.org? It will help to speed up the troubleshooting.


thanks for the file.

If you have the PDF Architect Pro or at least the review module, you can get rid of the symbols by clicking on "hide comments" in the review module. Probably they used to be hidden by default, it doesn't look like a bug.

Best regards


That worked, thanks Robin

I just got some time to check through the options and I don't see where I can permanently set to "Hide Comments". Am I overlooking something?

Hi Guys, New to this program, but if you set the AutoCAD System Variable PDFSHX to 0, the comments don't get created by the AutoCAD PDF drivers. Still can't find a way to remova all comments from a pdf in PDF Architect though.

Hi guys,
I'd also appreciate if I can choose to HIDE COMMENT permanently. Not in every drawing.
Thank you

I'm having the same problem. Still no default setting to hide comments?

Hello, I am a noobie in arch/interior design world. But had graphic design exprerience 20yrs. In my case, after when I ploted dwg to pdf, I do 1 more step to preventing any uncertain printing issues, that solved cad pdf file's hidden ghosts showing out. (am a Adobe acrobat user). my 1 more step is, open dwgPdf file ---> save as ---> Encaptualted PostScript format. that means, it breaks all fonts & tables etc... Next step, use Acrobat Distiller to create PDF. Then your dwg pdf became encaptualted, flattened, it all good to go.