V1.7.1, Stampstring, Changed Page Orientation, Extra Page

Just upgraded to 1.7.1 on Windows 7, 32bit. All worked OK with prior versions. Now, with anything in stampstring field, page is changed from portrait original to landscape and an extra, blank page (with the stampstring, though) is added. If original is landscape, output is portrait and extra page is added. This occurs in email attachment and by auto opening document in Adobe Reader. Clearing stampstring field fixes problem.


  Thank you...


I got the same problem on Win XP, too. I print web pages from browsers (MS-IE 8, SeaMonkey 2.17.1), .doc documents from MS-Word, .xls from MS-Excel and so on.

I tried to drop undesired extra pages using PDFArchitect version 05.5.509. However, if a document is protected by a password in order to modify it but not to open it, this program fails to open it. Obviously, I provided the correct password!

I hope a solution to these problems.
Thank you.


allthough it is a big mistery to me how I didn´t notice this while testing, it can be resolved by manually installing Ghostscript 9.05 and pointing the PDFCreator to it in the “Ghostscript” section of the PDFCreator options. ( http://sourceforge.net/projects/ghostscript/files/GPL%20Ghostscript/9.05/ )
It is a GS issue and we can´t really do much about it.




  Thanks for the reply. Using GPL GS 9.05 takes care of the extra page for me. The page orientation is still being swapped when using the stampstring option. Any ideas? I have uninstalled all and have reinstalled. Thanks! PK

Thanks, Robin. I installed GS9.05 and selected it in PDFCreator option. Extra page with stampstring is disappeared.

PDFArchitect version 05.5.509 problem is still there. In my opinion, the correct behaviour should be: open the document but not allow you to change, because it is password protected for modifications not for reading.
P.S. I did not install the newest version of PDFArchitect as it is too invasive, for my rare use.


I didn´t have issues with the page orientation here, you can try changing the auto rotate settings under formats->pdf, mine is set to single page. Did you verify the document gets printed correctly without the stampstring?



OK - Now working. I uninstalled all (again). After new installation and config, PDFCreate is working for me as it did before. Not sure why. Thank you for your time and the help on using a previous GS.


In PDFCreator 1.7.2, which was released 2 days ago, I don’t feel any more problems. It seems to be the stable follower version (after 1.6.2.). Thanks for releasing it!