Cannot install v2.5.1 on Win2K3 server


#1

I need to have PDFCreator on a Windows 2003 server (32bit). I know, it’s discontinued, but still, there’s that need.

Executing PDFCreator-2_5_1-Setup.exe on the server does… nothing! No messages, no task in task manager, nothing. I also tried the setup of v2.4.1 and v2.2.2. The same thing. Also, no messages in the Event Viewer. .Net from 2.0 up to 4.0 are installed.

Any ideas on what else to check?


#2

Hi,

in theory it should work, as XP is currently still supported and 2003 should therefore be, too.
I know there is an issue in Vista where you need to unblock the executable in the file properties before executing it, maybe they also integrated this into the 2003 server, could be worth checking. I will check if we still have a VM for this and have a look at it if possible.

Best regards,

Robin


#3

Thanks.

The funny thing is that the setup for 1.7.3 works fine. Also, since the server is in a VM, i took a snapshot and played a little. I even disabled the antivirus, firewall and in general everything security-related, but no luck. The problem is that there is no message to at least point you to something.

I hope you can find something on it. in any case, thanks for your time.


#4

Hi,

one thing that is required on XP is SP3, but I think mainly becasue of .NET 4. I was able to find a fitting VM, the setup at least executed properly but then ran into an error installing .NET 4 which I will now look into.

Best regards,

Robin


#5

Well:

https://technet.microsoft.com/en-us/windowsserver/bb463273.aspx

QUOTE: Windows Server 2003 SP3: There is no Service Pack 3 for Windows Server 2003, and none is forthcoming.

There is SP2 installed on the server (not fully patched though).


#6

Hi,

I am afraid I can’t reproduce the problem so I can’t really help.
Though I should mention that I did encounter a different problem at the end of the setup as it wasn’t able to install the printer properly. I will need to check back with our team which components from the XP SP3 are required and if they are available for server 2003 or not.
But the setup should at least run on a fresh 2003 VM, so there seems to a an additional conflict in your case.

Best regards,

Robin


#7

Well, he who searches, is bound to eventually find something (not always nice) :slight_smile:

Anyway, i would really like a solution for this matter so if anyone is going to spend any time on this matter and perhaps wants me to run a debug version of the installer or something, i’d be happy to.

Thank you very much for the time you spent on this Robin.


#8

One more thought on this, perhaps it is related to the terminal server check in the setup, which won’t allow you to install the freeware on a terminal server. This would usually display an error message indicating this, but perhaps this is broken for Win2k3. Does the terminal server installer show the same behavior?
http://download.pdfforge.org/download/pdfcreator-terminal-server
(you won’t get through the install without a license key but it might pin down the error if this at least loads the initial dialogs)


#9

Well, executing the PDFCreator-Terminal-Server-2_5_1-Setup.exe had the exact same behavior as the previous attempts i made. I’m not connecting through terminal services though, so i did not expect it to be the case anyway (i’m not even sure if they are enabled on the server).

Following your link though, i noticed that the TS installation has two options, an EXE and an MSI one. I downloaded and tried the MSI one and… Success! I saw a UI and was able to continue until i had to press the “Install” button for the process to begin (which i didn’t). Is there an MSI for the free version? I couldn’t find one…


#10

Hi Robin.

Any chance perhaps of having an MSI installer somewhere for the Standard version of PDFCreator, or perhaps a workaround for this issue?


#11

Hi,

I am afraid there is no MSI for the standard freeware but there is one for PDFCreator Business and we could create a test license for it to see if it has the same issue. When installing the MSI there is no option to enter the license key during the setup, so it will always fail if no license key is provided through the command line. Additionally, it is required to run the MSI from an elevated command line in order for the instalaltion to be successfull. Last but not least, the MSI must be able to contact our license server license.pdfforge.org, if any of the 3 conditions isn’t met, the setup will fail.

Best regards,

Robin


#12

Well, i could try that. I have administrative permissions on the server, so i can test if it installs properly or not. From what i understand though, this will be a test for a different problem than the one i’m facing (where running the setup does nothing), right?


#13

Hi,

yes, just trying to find any solution for you to install PDFCreator right now, the other problem is still a big mistery and it might not be possible to solve without additional information/it happening elsewhere. Did you ever check if there is a block/unblock option anywhere in the files security? It took us some months to find out this was causing the exact behavior you describe on Vista machines for any setup above v. 2.1.

Best regards,

Robin


#14

:astonished: :astonished: and again :astonished:

I don’t believe it. In the file properties (ALT+ENTER), the “this file came from another computer” message had appeared! When i pressed the “unblock” button, it worked and installed normally! The funny thing is that this message appears also in the 1.7.3 setup, but it’s being executed and installed normally. In the 2.x setup, it just does not produce any message. How nice. As if it’s been designed to drive you crazy. Anyway, many thanks for the pointer.

OK, it seems that my problem was solved, plus i have verified that v2.5.1 can be installed and run under Win2K3. If i can help in any other way, please let me know.