Command line interface /optionfiles.../nostart


#1

Hi all
I’m novice in using PDFcreator 1.0.2 and I’d like to convert .doc files into .ps with different settings the default printer has.
So I installed a PDFprinter by running /printername=Myownprinter.
This printer has been succesfully installed with the default profile.
Afterwards I created a .bat to put a .doc files into the Queue. I did and ran first :
“C:\Program Files (x86)\PDFCreator\PDFCreator.exe” /OptionsFile"C:\Moritz\TestPCNE\MyPCNE.ini" /PF"C:\Moritz\TestPCNE\1160-02.doc"

It seems to be alright, the .doc has been converted through the attached inifile.
But as the help says with the /PF option the PDFcreator.exe remains running.
To close it You have to put /nostart into the command line.
(I do no understand why this option is not called /autoclose…but it’s not the subject here) but with /nostart like :
“C:\Program Files (x86)\PDFCreator\PDFCreator.exe” /nostart /OptionsFile"C:\Moritz\TestPCNE\MyPCNE.ini" /PF"C:\Moritz\TestPCNE\1160-02.doc"

It did not work as I thought…
It does not load the /optionfiles setting.
So my .doc file is converted using the default profile then asked me for the output name.

What I did wrong ?
How could I convert a file from the command line and without using the default profile ?
(I’d like use several different settings depending on different use)
Is there a hidden setting which allows to convert with a specific Profile or printername
or Do I have to implement myself something using the COM objects ?
Thanks in advance for any advices.
regards


#2

Nobody can help us with this problem?


#3

Someone solved this problem already?


#4

This problem ist actuelly for version 1.6.2 too!
Someone solved this problem already?


#5

Hi,

http://www.pdfforge.org/content/settings-pdfcreator

Since version 0.9.9 the old ini mode is not supported anymore.

regards,

Robin


#6

Nice answer… So instead of offering another way, you just say “not supported”… LOL


#7

The alternative solution was described in the link, which now, 5 years later, has become outdated.
This should’t be an issue in any of the latest version.

Best regards

Robin