Copy and paste with PDF creator version 2.5.1.5 and Adobe Acrobat reader version 2018..009.20050


#1

I use PDF creator to save on paper and becasue I do not have a printer. I have print documents that I find on the web to pdf creator so that I can read them when I am offline. Recently I have been trying to copy and paste code snippets from documents that I have printed to pdf. The copy works find but when I try to past them into wordpad or notepad I get a jumble of incomprehensible characters. For example:

“is hoping that OneDrive will be the place” (I typed that quote in by the way")

Paste in as:

034=790,R4>=8>4+,-./01-4S0XX4?-4>=-49X8<

That might be an acrobat reader problem but I am posting this help message here just in case.


#2

Update: I have determined that this is a problem with PDF creator rather than with Adobe Acrobat reader.

I upgraded to a new laptop about a year ago. I transferred most of my files from the old laptop to the new one then I reinstalled PDF creator from a the download site since I had somehow lost the original zip file.

All those old documents that I transferred over copy and paste just fine. But it is the newer document that I made after I reinstalled PDF Creator on the new laptop that have the problem.

Any help please.


#3

Hi,

as far as I know this is mainly an issue with the application which originally printed the documents, especially browsers don’t print Fonts as expected in a lot of cases. I am afraid there most likely isn’t anything we can do about this.
You could try printing from a different application to work around the issue.

Best regards

Robin


#4

I am going to test this out by using pdf creator to print a document that I already had on my system prior to upgrading. I will get back to you. I just cannot see why copy and paste works on documents that I had previously printed with pdf creator but not on newer ones.


#5

Ok here is a copy and paste from a page that I originally printed with pdf creator on Jan 10th 2015 I last accessed it on April 15th 2017. Before I reinstalled and updated
pdf creator. Google for the class reference for EzCrypto Key Class to see the acutal page.I cannot post tthe link becasue this forum software will not let me post a link. Just in case you want to view the original page off the web.

“This may well be the only crypto class for Python that you’ll ever need. Think of this class, and the
ezPyCrypto module, as 'cryptography for the rest of us”

I just went back to that page 5 minutes ago and printed and saved the pdf file with pdf creator to another location on my hard drive. When I tried to copy and paste from that NEW FILE of the SAME EXACT PAGE of the SAME LINES. I get this:

L<A;9JCM9>ENN9OE9D<E9=KNM9P@M?D=9PNC;;9I=@9QMD<=K9D<CD9M=RSNN9EBE@9KEEGT9L<AKU9=I9D<A;9PNC;;V9CKG9D<E9EWQMX@M?D=
J=GRNEV9C;9SP@M?D=Y@C?<M9I=@9D<E9@E;D9=I9R;ST

This tells me that the problem is with pdf creator since both files were made with the program just older and newer versions.

.


#6

Hi,

thank you very much for the update, we will have another look at this.
It must be related to how Ghostscript (which we use to convert the Postscript file to PDF) handles Fonts, as we didn’t make any changes to PDFCreator itself in regards of fonts that I could think of. We did however update the Ghostscript version a couple of times. This would however might make it impossible to fix on our end, if it needs to be fixed in Ghostscript itself. Does priting from a different browser also lead to this issue?

Best regards,

Robin


#7

Ok thank you. It is getting really irritating… I do not mean to complain. pdfforge makes a great product. I just hate when something use to work but after and upgrade does not work the way it use to. I have had this happen with several programs. I make me hesitant to upgrade anything. I like to adhere to the old adage. “If it ain’t broke do not try to fix it”


#8

Hi,

I can totally understand that, it affects us just as badly. We rely on multiple other software for PDFCreator to operate properly (Ghostscript, Windows. .NET) and every time one of them receives an update, we need to have a very close look at it to figure out whether or not we could/should use it for PDFCreator or if we need to change some parts of on our end to ensure compatibility to new or changed Windows functions. While we do have a lot of automated tests which already cover the vast majority of the functionality, an issue like the one you describe is very hard to detect automatically.
Did you try printing from a different browser already?

Best regards

Robin


#9

No I have not tired using it in anything other than chrome. I can try Firefox tonight. Is there a location where I can download an older version for windows?


#10

Hi,

previous versions of PDFCreator are available for download here:
http://download.pdfforge.org/download/pdfcreator/list

Best regards

Robin


#11

Robin: Here is an update.
I took your advice and tried printing with different browsers then copying and pasting into wordpad.
This first example was created using google chrome about 4 years ago:


date modified 1/16/2015
date created 2/8/2018
Pdf Producer: GPL Ghostscript 9.10

ezPyCrypto is the culmination of my search for an approachable yet powerful crypto library for
Python

This was done today with firefox

Firefox
date 03/10/2018
PDF Producer: PDF Creator 2.5.1.5
ezPyCrypto is the culmination of my search for an approachable yet powerful crypto library for Python.
This was the same page printed then copied and pasted TODAY using google chrome

Chrome
date 03/10/2018
PDF Producer: PDF Creator 2.5.1.5

89:;<=;>?@ABCA?D8AEFGHBIJ?B@IA@KAH;AC8J=EDAK@=AJIAJ>>=@JEDJLG8A;8?A>@M8=KFGAE=;>?@AGBL=J=;AK@=A:;?D@IN


So it seems the culprit is goggle chrome using pdf creator 2.5.1.5


#12

I have the same problem with versions from 3.0.0 (Sept 2017). But the problem appears only when I make PDF from Opera or Chrome. When I print PDF from Firefox, Notepad, LibreOffice, WordPad, GStarCAD, there is no problem, that is normal text appears after copying and pasting. I tried to downgrade to version 2.5.3, but once I installed version 3, the problem appeared in 2.5.3, too. So I returned to the current version 3.2.2, and when I have to print PDF from Opera (this is the browser I always use), I choose the built-in PDF converter. In other softwares I use PDFCreator, which is the best PDF creation tool. I have tried a lot of other PDF creation tools (PDF24, Nitro, Sumatra, PDFXchange, Bullzip, Foxit), but only PDFCreator is suitable for me and I am used to it.

Thanks

Örs


#13

Hi,

this isn't a PDFCreator bug, so it doesn't matter which version you use. PDFCreator is and has always been a virtual printer and if the printing application (Opera, Chrome) decide to send vector images to the printer instead of actually sending the real text, it will result in a PDF which isn't searchable and doesn't contain any actual text (only image of text). Other tools will suffer from the same issue unless they use OCR or aren't based on virtual printers.

Best regards

Robin


#14

Sorry, you are right. I've just exported may email from Opera using PDFill PDF&Image Writer, and the result is the same, so it is an Opera/Chrome bug. Why have I thought that it is a PDFCreator bug? Sorry, and thanks!

Örs