Dokumentenname <REDMON_DOCNAME_FILE> unter AutoCAD 2010


#1

Ich benutze PDFCreator um Zeichnungen von AutoCAD auf PDF auszugeben. Bis vor kurzem war auch alles soweit i.O. (XP)

Nun habe ich einen WIN7 Rechner mit AutoCAD 2010. Hier bekomme ich aber immer die Bezeichnung "Model 1" mit angehängt.

Vorher: "Zeichnung.pdf"

Jetzt: "Zeichnung Model (1).pdf

Das kann ich zwar von Hand ändern, aber vorher ging das doch auch. Die Einstellungen sind exakt die gleichen, also könnte es an WIN7 liegen? Oder doch an AutoCAD?

Hat jemand eine Idee?


#2

Das liegt an AutoCad. Dieses übergibt beim Drucken diese Informationen mit.


#3

Anscheinend benutzt keiner AutoCAD hier und hat die gleichen Probleme?

Ich habe immer noch die gleiche Dateiausgabe Bezeichnung.

Hat denn keiner eine Idee?

Danke und Gruß


#4

Hi,

 

in den Einstellungen unter Speichern befindet sich die Option "Dateinamen Ersetzungen", dort auf der linken Seite Model (1) (bzw. Model 1, es muss der exakte string mit Leerzeichen etc. sein) und auf der rechten Seite leer lassen, auf Hinzufügen und dann auf Speichern klicken.

 

 

Robin


#5

Das war die Antwort! Funktioniert endlich. ;-)

Danke sehr!

 


#6

Mittlererweile haben wir 2015 und die Version 2.1.1.
Da ich hoffte das das Problem mit den Dateinamen in dieser Version behoben ist, habe ich diese installiert und war aber enttäuscht, das ich wieder nicht den Dateinnamen als Vorgabe bei der Ausgabe bekomme. :frowning:
Ich werde also wieder zur Version 1.7.3 zurückkehren. Hier klappt alles einwandfrei.

p.s.
oder hat jemand Lösungen gefunden?

Problem kurz dargestellt:
mein Ausgabe PDF heißt z.B. "C_Users_Tigerfisch_Documents_Drawing1 .pdf"
Das Ergebnis sollte aber sein "Drawing1 .pdf"
Wie gesagt, bis Version 1.7.3 funktioniert das auch, aber leider (noch) nicht mit den Neueren.


#7

Hallo Tigerfisch,


welche Tokens hast Du in den jeweiligen Versionen verwendet? 

beste Grüße,



#8

In Version 1.7.3 hieß der Token .
Seit der nicht mehr gelistet ist funktioniert es auch nicht mehr. Der Token   zeigt wieder den kompletten Pfad mit an.
Ich hatte gerade mit der Version 2.1.2 getestet.


#9

Ach ja, das kam noch dazu: Auch die Dateinamenersetzung “Model (1)” funktioniert mit den neuen Versionen nicht mehr. :frowning:
Bis es Lösungen gibt, werde ich wieder die 1.7.3 installieren.


#10

Hallo Tigerfisch,


hast Du es schon mit dem Token versucht?

beste Grüße,



#11

Hallo Robin,

ja habe ich selbstverständlich auch, aber hier funktioniert es nur “teilweise”. Hinter dem Filenamen setzte er wieder das “Model (1)”, also z.B. -> “TestZeichnung Model (1).pdf” !
Obwohl ich bei der Dateinamenersetzung “Model (1)” = leere Zeile , eingesetzt habe.
Ich habe schon mehrere Kombinationen durchgespielt, aber bis dato immer noch das nicht zufriedenstellende Ergebnis. :frowning:

p.s. ich benutze inzwischen auch die Version AutoCad 2014 deutsch, aber hieran kann das ja nicht liegen, da mit der 1.7.3. es ja auch läuft.

norddeutsche Grüße


#12

Moin, lang ist es her, aber wieder da mit ähnlichen Problemen.
Ich benutze Autocad 2019 und PDF Creator 3.4.0 aktuell.
Wieder habe ich bei den Zeichnungen das ... Model (1) stehen. Man kan es bei den Tokens ja ersetzen, aber bisher ist es mir nicht gelungen.
Vielleicht gibt es inswischen jemanden der die "richtige" Schreibweise kennt. :wink:
Beispiel: Zeichnung heißt "Test Model (1).dwg". Ziel ist es: "Test.pdf" rauszubekommen.
Danke und Gruß


#13

Moin,

versuch bitte einmal folgendes Title Replacement: " Model (1)" (Ohne "")

Aus meiner "test Model (1).dwg.pdf" wurde damit "test.pdf"


#14

Ja, danke für die Antwort.
Das habe ich zum Teil auch hinbekommen, aber nur wenn unter profile - speichern bei Dateiname steht: "printjobname". Allerdings steht dann vor dem Dateinamen der Pfad.
Wäre interessant wenn du mir ein Bild schickst mit den Einstellungen unter Speichern und Metadaten.
Vielleicht hilft das weiter.


grafik


#15

In der Tat ist es so, dass die Titel-Ersetzungen genau genommen "PrintJobName" Ersetzungen sind.
Eine mögliche Lösung wäre, den Pfad mit Hilfe eines regulären Ausdrucks entfernen zu lassen, etwas anderes fällt mir leider nicht ein. Wir haben das Problem aber bereits erfasst und diskutieren derzeit verschiedene Lösungsansätze.

Beste Grüße

Robin


#16

Hallo, ja das wäre aber ein Rückschritt... :roll_eyes:
In der Version 1.7.3 z.B. gab es mehr Einstellmöglichkeiten. Hier gab es u.a. den "DocumentFilename"!
Der funktionierte. Vielleicht mit integrieren, bzw. wiederbeleben?
Würde mich freuen wenn das zügig klappen könnte. :wink:
Danke.


#17

Hi,

den DocumentFilename bzw. InputFilename gibt es ja immer noch, nur werden darauf die Titelersetzungen nicht (mehr) angewendet.
Wobei InputFilename auch nur den ggf. vorhanden Pfad aus dem PrintJobName herausfiltert, der tatsächliche Dateiname wird nicht als solcher an den Drucker übermittelt; dass sollte aber früher nicht anders gewesen sein. Es wäre natürlich trotzdem schön, wenn die Ersetzungen einfach auf alles angewendet werden und man nicht auf reguläre Ausdrücke zurückgreifen müsste.
Reguläre Ausdrücke sind etwas kompliziert und oft nicht ohne Nachschlagen zu verwenden, dafür lassen sich hiermit aber wirklich alle Fälle abdecken. Für Deinen Fall sollte folgende Einstellung (mit PrintJobName als Dateiname/Titel) funktionieren: Mit regulärem Ausdruck ersetzen, Suchen nach .*\\(.+)$ ersetzen durch $1
Dadurch wird der ganze Pfad abgeschnitten, die schon eingerichteten Ersetzungen sollten den ungewünschten Rest am Ende beseitigen, sonst bitte nochmal Bescheid sagen.

Beste Grüße

Robin