InputFileName adds a space between file name and .pdf


#1

I have been using PDFCreator 1.7.3 for a long time and our company purchased a new computer and installed the latest version 2.53. I used to use the token but the new version does not have this, it looks like token does the same thing though. Our PDF’s are made from AutoCAD and these tokens take the file name and also the “Layout” name and use them for the PDF name. We found the putting a “.” in front of the Layout name keeps this from being added to the file name which really works well for our needs. My problem is that the latest version of PDFCreator adds a space between the file name and .pdf (11704-3321 .pdf). I am hoping someone has any ideas how to keep this space from being added.

Sorry for the long winded explanation, I am just hoping more information might be helpful.

Thanks in advance for any information!

Romey


#2

Hi,

which token are you currently using (write it without the brackets, or escape them as the forum otherwise treats them as HTML and the content between the brackets becomes invisible)?
In general, any substitutions in the filename can be configured in PDFCreator application settings->title.

Best regards,

Robin


#3

Hi Robin,

I apologize, I didn’t realize the brackets would be a problem.

The token I use on 1.7.3 is DocumentFilename but the new version does not have this token.
I found that the token InputFileName works the same except for the space that is now added.

Thanks for your time.


#4

Hi,

I am not sure why the space is added, or why the layout name doesn’t get used if you put a dot in front of it.
Is the name for the layout always the same?
Please try using the <PrintJobName> token as an alternative.
I will check if it is possible to reproduce the problem here.

Best regards,

Robin


#5

Hi - I am having this problem as well. I just updated my Windows 7 and I am running PDF Creator V3.3.0. I have tried different tokens from the drop down list and they all end up with blank spaces after the file name before the .pdf. This results in an error message when the system then tries to email the file as an attachment as the file it is looking for has no extra spaces - File name that is saved is Inv-0007896 .pdf and the file the email is looking for to send is Inv-0007896.pdf.

Any ideas? - Just to clarify as well - there are about 10 blank spaces between the file name and the .pdf

Ok - one more, I just checked another computer that has Windows 7 update done, but is running PDF 2.0 and it worked fine - No extra spaces.