PDFCreator 1.7.3 suddenly seems to stop working


#1

Hi y’all!

even though support for v1.7.3 has ended a couple of years ago I’m still hoping for an answer.
We’re using PDFCreator as a way to automatically create PDFs from RTF files by starting the PDF creator process with parameters “/PF” from our application. This seemed to work quite well for a while but occasionally the PDFCretor stops working and doesn’t convert any files. Even if I manually start the PDFCreator and try to load a rtf file nothing happens. Right now, only a reinstall seems to help. After that, the PDFCreator is working again for a short period of time.
The PDFCreator log doesn’t say anything, by the way.

The described problems are occuring on both Windows Server 2008 R2 and Windows Server 2012.

I hope somebody can help.

Kind regards


#2

Hi,

sounds like a permission problem with your user accounts %temp% folder.
Did you set the logging level to “trace”?

Best regards,

Robin


#3

Hi Robin,

thanks for the fast response. How to set the log level to trace? There are no log settings in v.1.7.3.

Best regards,


#4

Hi,

I am afraid I am not 100% sure where the setting for this was in version 1.7.3, perhaps it is a hidden setting in the registry or version 1.7.3 only had an on/off switch for the logging. Have you checked the permissions for the folder %temp%\PDFCreator? It really sounds like the problem is caused by those.

Best regards,

Robin


#5

Hi Robin,

permissions are OK but I noticed something yesterday while checking the permissions on the %TEMP% folder.
On one machine, which stopped the proccessing of RTF files, I found 2 PDFCreator folders. The first one directly in %TEMP% dir - which was empty and the second one in "%TEMP% / 1 " which contained hundreds of *.ps files which weren’t processed. I tried to copy a couple pf *.ps files from %TEMP%/1 to %TEMP% and all of a sudden the PDFCreator processed the file.

We are using both RDP and TeamViewer to connect to the server machine. Can you explain what’s happening here?

Kind regards,


#6

Hi,

this is probably related to which session ID the print jobs are coming from and it might not be possible to fix this in v 1.7.3. It sounds like it is writing the spool files to %temp%\1 but looking for them in %temp%

best regards,

Robin


#7

Hi Robin,

wouldn’t disabling the group policy, which is responsible for creating additional temp folders for each session, fix this problem?

Additionally we noticed on another machine that the *.ps files are created in C:\Windows\Temp. Can you explain this? (Env. variables are correctly set for the user).

Regards,


#8

Hi,

disabling that group policy could solve the issue, I wasn’t aware of this but it sounds like it is worth a try.
I am afraid I have no idea what could cause the temp files to get spooled to that path, apart from the environment variables.

Best regards

Robin


#9

Hi there…

Having this same issue in here… Same versions of windows and PDFCreator.
Was this issue solved ? How ?

Thank you very much or your help.

Faber


#10

There haven’t been any reports about this in current releases, updating should solve the issue.