This is driving me MAD


#1

G’day to anyone reading this subject.

I had a thread running about this problem ages ago and it was never resolved, except by dumping the current versions and installing an old version.
I have a very large document(s), <---- 2 metres ----> x 350mm.
I have a suitable page size set in Windows Print Server Properties-Forms that matches the document size.

Using PDFCreator 1.6.2 the one that’s not had the Optiions/Configs guts ripped out, I can print this and similar large page sizes to PDF without any difficulty.

Post 1.6.2 This has been impossible no matter what I tried.
I therefore didn’t allow 1.6.2 to be updated and all was and is well, still is on my Desktop computer.

Old Laptop died recently so sourced a new one and thought why not give PDFcreator lastest version a go, that’s PDFCreator 2.4.1
Well again, what a waste of time that was, it just will not PDF the large document.

So folks, before I go off on one… Dump the new version of PDFCreator in the rubbish bin and install 1.6.2 on the Laptop, can I ask for a step by step, How do I get this latest version to print my expleting large document to PDF… Please!

I have a large document <---- 2 metres ----> x 350mm.
I have a suitable page size set in Windows Print Server Properties-Forms that matches the document size.

Now what do I do with PDFCreator to get it to print my document to PDF?

Thanks
Ax


#2

I was hoping someone would start me from scratch, but it seems not to be the case, so I’ll fill in some additional info in the continued hope of some useful additional advice arriving. :frowning:

Windows:
Print Server Properties:
PDFCreator is selected.
PDFCreator is set to use the large page size I created “2K350mm”
[The same page as used by PDFCreator 1.6.2]

The AppX used to create the document is set in the Print dialogue to use PrintPDF.
[Exactly same as in PDFCreator 1.6.2]

From the AppX print dialogue, Advanced settings, PDFCreator is set to Paper size: “2K350mm”.
[Exactly same as in PDFCreator 1.6.2]

Regardless of orientation selected, beit Auto, Portrait or Landscape, PDFCreator will only create to an A4 size.

[Unlike the 1.6.2 PDCreator that honours the page setting, because it has an Options “Document dialogue” “Document properties 2” which has a section for paper size entries, in the form of “Used fixed paper size” or Use custom page size" Where I have obviously set the large page size calculated in 1/72 of an inch.

There is no Options dialogue of this sort in the post 1.6.2 versions of PDFCreator.

Madness…

Thanks
Arturox


#3

Hi Arturox,

the options for the paper sizes were removed as they could only be used to cut off contents extending the size, they never performed any scaling and therefore were discontinued.
The current PDFCreator version should honor the settings of the printing application, is it a common app or something where we could install a trial for testing purposes?
We will gladly have another look at this.

Best regards,

Robin


#4

Thank for the reply Robin.
Sorry, I don’t actually understand the first part of your reply?

The second part…
The App in question is not a common app, probably little known, It’s called “Ovation Pro”, a Document processor I use for most of my Document work.
AFAIK There isn’t a trial version, but the fact it works perfectly okay with PDFC 1.6.2 and earlier means something along the route from 1.6.2 to today got broken.

Anyway, you’ve set me thinking, today (UK Wed 1st Feb) when I get time, I’ll create an oversized document in something else, Probably LibreOffice and see what happens when I use PDFC to print that to a PDF.

I will report back on that later…

Ax


#5

Okay I return after some brain bashing.

Laptop running Win 10 and PDFCreator 2.4.1

As previously noted my wide documents out of my usual OvPro will not print to PDF on any Post PDFC 1.6.2

Created a same size document in LibreOffice, Printed it through PDFC 2.4.1 and it did in fact print correctly.

Take the new LibreOffice document to the machine with PDFC 1.6.2 and it will not print to PDF correctly.
Even when I’ve changed the setting all sorts of ways.

So obviously something got messed up when the UI of PDFC was changed.

Ax


#6

I’ve done some more messing this afternoon and made no progress, so I guess the situation will have to be as before.

I have quite a number of OvPro large documents created over the years, their re-creation in some other app would be unthinkable at this end of my life, and having played with LibreOffice again today, beyond a nightmare.

I think the only satisfactory answer is, stick with PDFC 1.6.2 for the forseable future for those documents.
No biggy, just an annoyance.

I’ll keep a later version on the Laptop for other documents.

Thanks
Ax

Shame I can’t have two different versions of PDFC installed on one machine, then select the one appropriate for the particular document. :wink:

Ax


#7

Back for a little footnote. (Not a moan, just for info)

After doing one last bit of testing, Obviously using my default app, I’ve found that PDFC 2.4.1 printing out of my default app, will not correctly pick up any User defined paper size I have in the Windows Print server Properties.
It works okay with pre-defined default sizes.

Whereas 1.6.2 does work okay with various User defined sizes.

At least I’ve now got my head around the foibles and know what I need to do.

Righto that’s my lot,
Goodbye.
Ax


#8

Hi,

we also had another look at this and were able to find some cases in which the paper size didn’t get set properly for 2.4.1, too. We will run some more tests with the additional information you provided in mind.
Thanks for the updates and sorry for the trouble.

Best regards,

Robin


#9

I will watch with interest to see if you find anything…

Ax


#10

I found a little time to do some more testing on this and here is what I have found out so far:
If you create a new form in the print managament and the printing application lets you select this as available paper size, it will work.
Next I will look for an application which doesnj’t allow setting a paper size at all and see what happens there.


#11

Did you use two different machines (with 2 different Windows versions) for testing this?
Under Windows 10 some applications ignored the default printer settings and I needed to set the page size for each print job, using the systems printer dialog but from inside the application in order for it to work. Setting the page size in the systems printer dialog through the Winodws control panel didn’t show any effect on these applications at all.


#12

Hi Robin, Thanks for looking into this business.
I’ll answer both in one posting.

That’s not what I was finding, as the form I was using/selecting (The wide one) was created by me, and after processing (Printing) it was only creating an A4 sized bit of the whole document.

No, both machines running Win 7 pro SP1 64 bit.

Remember I found that 2.4.1 worked okay if I selected one of the Windows original Forms, but not any new user created forms.

I was selecting the form through the application print dialogue.

As a while has passed since I originated the question, I’m a bit rusty on what I actually tried, so this evening (UK time) I’ll install 2.4.1 again, go through the process in light of your postings and see what happens.

Will come back with some notes then.

Ax


#13

Well, what can one say. Blaaaaa!

Again, I uninstalled 1.6.2 and replaced it with an install of 2.5.1
I’ve done a number of tests with different configurations, below are two that sumarize the results.

Test 01:
Ran the original OvPro DTP app.
Opened the print dialogue, set the (My created) large page.
Continued with the print to PDF.
Afterwards it opened in Foxit PDFreader, all I have is an A4 sized part of the large document.

Into Windows, Devices and Printers, Print Server properties and created a completely new meduim size form.

Ran the DTP app with a new smaller file and did the print process, selecting in the print dialogue the new medium size form size.
End result the same, the eventual PDF contained only an A4 sized piece of the whole document.

Test 02:
Used a different DTP app Serif’ Page Plus X9 (I’m assuming you will have heard of that app).
I’m in the process of manually transcribing one of my original files into PPX9.
So I now have a 2kmm x 350mm PPX9 document.

Prepare to print from PPX9
Using PDFCreator, set up its print dialogue to use the large 2K350 form.

Print.
It prints to PDF correctly, thus when opened in Foxit PDF reader the whole document is there.

Obvious conclusion, OvPro is not interfacing with new revamped PDFCreator correctly, particularly with new user created Forms.

[Not forgetting it works perfectly okay with 1.6.2]

I know and have contact with the Author/Coder/creator of the OvPro app, I’ll have a chat with him sometime and see what he thinks.

AX

A final thought… I still don’t like the new PDFCreator config pane and its dialogues, poor design to say the least…


#14

Hi,

thank you very much for your additional testing and the provided feedback, it really helps a lot.
I have to correct my own test results: When printing from any application on windows 10, A4 was always displayed as paper size when entering the PDFCretor printers setting from within the application, but not actually used unless you brought up the settings dialog, so if you configured the paper size directly from the windows control panel and then not touch the settings in the printing application it works in most cases. In Notepad++ it was the exact opposite and I needed to set the paper size for each print job using the PDFCreator printer setting from within Notepad++. So the behavior is really inconsistent among different apps.

Best regards,

Robin


#15

Mnnn! Interesting doings, I must have a play later with PDFC on my W10 Laptop.

But in the meanwhile, my problem printing out of the DTP app I use, “Ovation Pro” is now resolved.

I mentioned in a previous posting that I have contact with the Creator/Coder/maintainer of the app in question, and he reminded me of a PS printing configuration sub menu I’d completely forgotten about.

Unticking one entry in that config submenu sorted the problem.
Thereafter my test print to PDF was correctly processed by PDFC and the whole large document displayed in Foxit PDF reader.

Robin, thanks for your support on that one, appreciated.

Ax

There is a problem I’m having with 5.2.1
Whenever I use PDFC from within an App, the PDFC configuration pane pops up and squats under/behind the document and hold up the process until I ■■■ it out from behind and [X] it away.
The PDF creation process halts until I get rid of that pane (PITA). :wink:

I don’t need to see the damn thing every time I want to print something to PDF.

Is there a config somewhere I’m missing to stop that happening and thus stop it holding up the PDF creation process.

Thanks
Ax


#16

Hi,

you can either enable automatic saving to get rid of any dialogs all together and save all PDFs to a predefined path, or you can enable “skip print dialog” in profile settings->save in order to get only a prompt to select the outpout destination and filename.

Best regards,

Robin


#17

Oh if only it was that simple Robin.
I have two almost identical computers, both now have PDFCreator 5.2.1 installed with identical configs set.

On this one, I can print to PDF and not see that configuration pane.

On the other machine, that pane arrives regardless of what setting I have in the Save department.

And regardless, I don’t ever want to see that pane, unless I click for it.
Ax


#18

I’ve now sorted the problem on that other machine. :slight_smile:

I used Revo Uninstaller to uninstall PDFC everything.

Then I reinstalled PDFC 2.5.1 from scratch and the config pane is no longer a Pain. :wink:

Ax

Nb: I must get my version numbers in the correct order… I see I’ve been writing 5.2.1 instead of 2.5.1 Must be my age…