1.9.2 not printing automatically, files remain in spool folder

Hi, I have removed old 1.7.1 toolchain and now I’m using 1.9.2 beta build. It does work, when I do manually everything works correctly.

however, automated printing for strange reason does not work. This computer is running on 2012 Server. Fax service is setup to print to PDFPrinter, which would create PDF and run a script which would send a notification email. 

I have even changed logon details for FAX service to Local System, and I have enabled everyone’s access to fax inbox folder, but the problem is still there.

So whenever fax receives incoming message, it saves it as a TIFF file in its inbox, as per default. Then it prints to PDFPrinter, but in this case only two files are created in spool folder. One inf and one .ps file (one per each attempt). It looks there’s a glitch in the beta version which for whatever reason prevents automated printing, as then nothing happens.

Again, when printing same files manuall – everything works as expected.

Any idea how to resolve that?

Any logs available? might see where is going wrong.


yes you can set the logging level to debug in the application settings and send us the log or post it here, we will gladly have a look at it.



Hi, here’s the problem actually. there’s no log, even debug one :0

Well, the problem now is actually clear, by looking inside that log (for successful print).

In order to print, PDFCreator creates two files in its spool folder.

E.g. consider these two lines from successful print:


am I the only one who thinks that’s a problem already? Not even mentioning that the log is saved in a user’s subfolder as well… 

So what happens with PDFCreator is print is invoked by an app running under non-user account? E.g. for fax that could be network service or local system account. in fact I have seen troubles running fax service as a user account, even with admin rights (routing stops for unknown reason, for instance). 

For starters, spool is created in windows\temp folder, instead of user profile. But I reckon it is not probably tested and so other files not saved properly. 

Are you running PDFCreator as a service?

if you are running it as a service, it is recommendend to create an extra user for it with all required permissions.



Hello Robin,

no, in that environment I run PDFCreator as a normal user, as running as a service is only with svarny, right?

I used that configuration with 1.7.1 and that was buggy as hell. Even with that running as service I still have to have a logged on user on the server (not a problem actually).

In this case I use a logged on user over RDP. 

the problem that happens (apparently) is that PDFCreator would run under user that is assigned to Fax service, as it is the one which prints. Under normal conditions that is Network Service. 

Even if I run PDFCreator in my user account, apparently it will still be executed when printing under e.g. Network Service credentials.


Tested with the fresh 1.9.3, it’s better, files dont remain anymore in the printer spool, but it doesn’t work either.

Files tries to be writen in AppData\Local\Temp\2\PDFCreator\Spool which install the program. We find in the log in debug mode a problem to find the spool. Affecting rigths to anybody, we dont have the error, but files never appears ans nothing appears.

We wanted to use a server in W2012 to convert document and send then by mail.

Everything is OK in local, but not with a share printer.




I am testing version 1.9.3 as a shared printer/service on a
network.  The server it is on is running
Windows Server 2008 R2.  All of the
clients are running Windows 7 64bit.  The
application works fine locally, but does not work as a shared printer.  Is the server option in version 1.9.3?




Hello. First of all, sorry for my bad english :slight_smile:

We are testing version 1.9.3 too in our Windows 2003 Server. We have used srvany to start PDFCreator a service and it run with an account with administrative priviledges. It runs ok locally but if we try to print from one of our PCs with Windows 7, the jobs appear in the server folder ( C:\Windows\Temp\1\PDFCreator\Spool ) but no pdf is generated.

After researching a while, it seems that when you print from another computer, the jobs are not stored in the PDFCreator spool directory C:\Documents and settings\UserPDF\Local Configuration\Application Data\PDF Creator. They appear in the directory C:\Windows\Temp\1\PDFCreator\Spool\ where the number 1 indicates the session number of the user who is printing the document.

It seems that the program “goes crazy” when printing from the network and gets wrong the spooler directory.

¿Any suggestions why is this happening?

Ah! I forgot to tell that if the user account which starts the service has logged into to server it works perfectly. But when the session end it stops working.

Thank you very much for such a great and powerfull tool.