429 (ActiveX component can't create object)

PDFCreator - www.pdfforge.org
PDFCreator 1.2.3 - Error message
          Error-Nr: 429 (ActiveX component can't create object)
          Modul: clsPDFCreatorMail
          Procedure: MSOutlookEmail
          Line:      50030
          Date/Time: 04-25-2012 / 10:05:55
 Windows 7 6.1 Build 7601 (Service Pack 1)
  [TerminalServer IsWinXPPlus IsWinVistaPlus IsWinVistaSP1 IsWindows7]

Please Help






What where you trying to do, when this error occured?

Have you tried using version 1.3.2?






ok Have update to 1.3.2 and I'm testing next week


I had the same problem a while back and it bugged me for days. Finally I find a vrey useful little tool, www.activextest.com, and it showd me the errors and gave advice on what to do.

 Download the required dll file and copy the extracted file to this folder:



Reregister Concerning File

If you are getting a file name in the error description, then it is possible that particular file is not properly registered in the system registry database. In such a case, you need to re-register the file with the help of Command Prompt.
  • Close all open programs, if any.
  • Click Start, select Run.
  • Type CMD and press ENTER
  • Type the following command:Regsvr32 For instance, if the name of the OCX file is vbalexpbar6.ocx, then type the following command: regsvr32 vbalexpbar6.ocx
  • Press ENTER to execute the command.
  • Finally, type EXIT and press ENTER to close Command Prompt.
This will fix error code 429.
If problem still occurs then perform the following tasks::
  • Reinstall Windows Script
  • Repair Windows Script File Information in Registry
 If problem still occurs then click here to fix Error 429

I’m having the same issue with a few computers all with different version of PDF creator. My IT does not like to update. The newer version seems to be an issue. I see the instructions above to Download the required dll. How do I know what the required dll is?


I am afriad the post above more or less looks like spam to me and wasn’t discoverd as the thread wasn’t touched for the last 4 years. Have you already tried to reinstall?

Best regards,


I’m having this particular issue now. What advise can you provide?

Are you getting this in a PDFCreator 2.x version? I am afraid previous versions aren’t supported any longer.
You can try to run the PDFCreator.exe as admin once or reinstall the application.

Yes I’m having the issue with the new installs of the software. Does the new version of the PDFcreator support programmatic generation of PDF’s?


it is possible to contol PDFCreator via COM to influcense the parameters for the the conversion, but it is still a converter, mainly to convert postscript into PDF. If you are getting this error in a 2.x version, please send the loggin level to “trace” in the debug section of the application settings, perform the action which causes the error and send the resulting log to support(at)pdfforge.org or post it here and we will have a look at it.

Best regards,