All PDFCreator versions (1.4.2 and earlier up to 1.2.3) suddenly have stopped working on all compute

A few days ago one user notified me that PDFCreator stopped working on his computer. I thought it was a problem on his computer but no, today I've checked two more computers, including mine (which has PDFCreator 1.2.3) and same thing, PDFCreator no longer works on any computer. All those computers have Windows 7 SP1 64 bits. I will check if computers running Vista 32 bits or XP have the same problems.


The symptoms are: you send a print job and PDFCreator will never pop up. If you manually launch it, it will not show any print job. However under the Windows queue there is a print job that may be either paused or in printing status. The Windows registry usually has one error event, on some computers it says somthing about bad controller, but on my computer I see this event:


"El administrador de trabajos de impresión no pudo cargar un módulo de complemento C:\\Windows\\system32\\spool\\DRIVERS\\x64\\3\\PS5UI.DLL, código de error 0xc1. Vea la información de contexto en los datos de usuario del evento."



"The printer manager cannot load the 'complement'(?) module C:\\Windows\\system32\\spool\\DRIVERS\\x64\\3\\PS5UI.DLL, with error code 0xc1. [...]"


And also a pop up from PDFCreator saying:

"PrinterTemppath: 'PDFCreator\\' = 'C:\\Users\\Israel.DAEM\\AppData\\Local\\Temp\\PDFCreator\\' There is a problem to access this drive or folder!


This folder has the correct permissions and is fully accessible. BTW on more than one occasion on the first computer I had to manually set the permisions for this folder because they were screwed and the folder was unaccessible by default.


I've tried a full uninstall (meaning uninstall from Add/remove, then remove printer driver package from printmanager.msc, then remove printer port, then remove printer monitor pdfcmon.dll that remains in registry, reboot and reinstall). I've tried versions 1.3.2, 1.4.0 and 1.4.2. It makes no difference. UAC is enabled and on high (all UAC prompts enabled) on all computers (same as always). Doesn't make a difference if user is admin of local computer or not.


It's weird that after a particular date PDFCreator has stopped running on all computers. I'm still investigating, but at this time I have no more information. Also if it's a software problem, why am I the only one with this problem? (I've searched on the forum and on Google).


Update 1:


I've just checked, on Windows XP SP3 (32 bits) and Windows Vista SP2 32 bits PDFCreator is still working.


Update 2:


The plot thickens! There is one single computer with Windows 7 64 bits where PDFCreator is still working. I'll check which version is it running when possible. SO far I have three computers where it doesn't work and one where it does (not counting the ones using 32 bits OS versions).

I don't understand anything. Now it's working in all computers! I haven't done anything at all and it's working once again. Maybe it's a leap-second issue? There is something wrong, becase it "exploded" most computers I have at hand, but seems to trigger at some specific times... Oh, well, of someone can figure this out.

Nope, on the computer where the problem started, PDFCreator still refuses to work. I'm using a program called PrimoPDF there, which seems to work reasonably well, but feature-wise PDFCreator is better. So I'll wait for a fix or updated version.

In case someone is watching this, I found the problem. For some unknown reason the permissions on the Temp folder where wiped out clean, no permission information was present. Once I restored the default permissions, I proceeded to install PDFCreator and it now works as always.


What I still don't understand is why that same day two other computers had problems with PDFCreator (one of them being mine). But since it has resolved by itself, there is little I can do in order to further investigate.

 I have a 32-bit W-XP computer that does this now all of the sudden.  Been using VBA in a spreadsheet to automatically create and save a PDF file to a particular directory.

Now, I can walk thru the VBA code and I know when I use the .PRINTOUT command in VBA, to send the print job to the PDFCreator job queue, no job ever appears.

And, if I want to print it manually, that is no problem. Its just the VBA automation that has suddenly broken.

Check the permissions on the Temp folder, that’s what screwed it on one of the computers. If it’s a software problem a System Restore to a date where you know it was working may help.