Architect version 9 crashes my PC and laptop

I am looking to move away from Adobe so I tried installing Architect 9.0. It caused a constant flashing of the screen and broke the OS. Even System Restore encountered problems. I had to doa clean Windows 11 install to fix it. I tried installing Architect 9.0 on my laptop next - same issue.
So now I have Acritect 8.0 running on my laptop to try it out - and I like it :slight_smile:
Before I install again in my desktop, I wanted to know if anyone else has the same or similar problems with 9.0? Or if it is a known problem and there is a patch or fix? I cannot risk my main PC again...

I have. I was installed and working initially. Then, recently it kept crashing. So, I tried to uninstall it but I wasn't able to. Customer service reps tried to help me for a month but nothing was working. So, I did the same thing, reinstallation of Windows 11, and deleted all installed apps/software in the process. When I tried to re-install PDF Architect 9.0, the same thing happened to my laptop, flashing screen and missing start and taskbar. I had to roll back to the version before the installation to fix it. I have 2 other PCs with 9.0 but no issues with them. I wouldn't try to reinstall it on my laptop, though.

Hi Paul and acukimura,

What are the technical specs of your laptops? I will be able to contact our developers and ask them.

Personally, I haven't heard much about flashing screen and/or missing start and taskbars while installating PDF Architect or PDFCreator, but I experienced the error myself a couple of times.

Microsoft Community has heard about it as well, and some suggestions for troubleshooting are rather interesting than helpful. Please have look yourself:

Looking forward to hearing back from you.

Best regards