Auto Rotating Pages

I've been digging around the forums here and have found a few references to this problem, but I'm not sure if there's anything I can do to stop it?  

I'm creating combined documents which have landscape, legal-size pages followed by, usually, a page or two of portrait letter-sized pages.  I can't seem to stop PDFCreator from rotating the letter pages to landscape.  

I've tried changing the settings at the printer level, as well as the PDFCreator options under Auto-Rotate Pages.  I've tried all three of the settings, "none," "all" and "single page" but it doesn't seem to make a difference?  

I saw one post that mentioned they'd had this problem since upgrading -- do I need to revert 0.9?

I'm using v. 1.2.3