Bug in newer versions: connecting to windows terminal services generates a new blank page printing


I've been experiencing a bug in the newer versions:

Every time I connect to a remote windows terminal service (rdp), the pdfcreator driver installed in my local computer generates a new printing with the title 'Redirected document from remote desktop'. this document is totally empty , unexpected and undesired, the remote computer does not have any printing job pending.

So I have to install an older version (1.2.3) to make this bug disappear.

Im using windows XP proffesional as remote desktop and several versions of windows to connect from (XP, Vista, 7) home and proffesional, all of them with the same casualty.



we will have a look at this, if you like you could try out our new beta (which is rewritten from scatch), it is unlikely it still contains this bug:





thanks for the answer.

I also tried to use this newer version and it seems to have the same issue as the previous one, so I decided to reinstall the 1.2.3 version.

Sorry not to comment that previously.

Having the same issue.  Each time I remote into a computer, PDF Creator is trying to print a blank page.  Using version


did you also experience this issue with 1.7.x versions or only for 1.9.x?
Does this happen, as soon as you log in, or when you start the first printjob?
If anybody still has a recent version installed and is experiencing this problem, please enable PDFCreators logging by pressing F2 on the print monitor and logging for the pdfcmon.dll by adding the DWORD Logging with value 1 to HKLM\SYSTEM\CurrentControlSet\Control\Print\Monitors\pdfcmon in your registry and post the logs here or send the to support@pdfforge.org 


I tried to reproduce this in version 1.9.4 but no unwanted documents got created.

best regards