Cannot open after program associated

I installed version 1.9.3 build 534 and declined to install PDF Architect.  I have checked the box to open after saving, and unchecked the box to open pdf files with pdf Architect.  I now get the error that “No program is associated to open PDF files”…which is ridiculous.  It further says “we recommend PDF Architect…”  Don’t want it…don’t need it.  Please let me know how to get past this so my documents will open in Adobe after saving.  If this can’t be done, please refund my license fee I paid.


do PDFs still open in your default viewer if launched manually outside PDFCreator?
Or was the default application for openening PDFs changed to PDF Architect, even though you chose not to install it?
You can chenge back the deafult application by right clicking onto any PDF and selecting “open with” from the context menu. Select the viewer of your choice and make sure to check the checkbox “Always use this application” (might be called slightly different, I am currently on a German Windows so I am not sure about the exact translation).

best regards,

Adobe Reader is the default for all pdf associated formats.  I double checked under Default Programs in the Control Panel.  (Windows 7 64 bit)  Your description of the process of right clicking and ‘open with’ is dead on the money as well…but it too shows Adobe Reader as the default.  Yet every time this program tries to open a document I am printing and saving, it says there is no associated program and wants me to use Architect.  Any other suggestions?

by the way, I can go to the saved document and double click it and it opens just fine in Adobe Reader.  Only time it won’t open is when it is supposed to open with I print (create) the document in pdfforge


thanks for the details, this does indeed sound like a bug. I will try to reproduce this here and see if it is fixed in version 1.9.4.

best regards,

I appreciate your help.

I just upgraded to V2.5.1 and now it is doing exactly the same thing - telling me there is no application associated to open PDF files and recommending PDF architect which I definitely do not want. How do I fix this?
I have been using PDFcreator for years and it never did this before.
Until it is fixed I will used an alternative
N.B. using Windows 10


Which program is your default pdf viewer? On my pc it is working at least for adobe reader dc and evince.
Did you un-check the option to open the file with PDF Architect?

If nothing helps you can use the “run script” action with the path to your favorite pdf viewer. But make sure to un-check the box to wait for the script to end.

Best regards

I’m using Win7 32bit, pdfcreator 2.5.1, default pdf viewer foxit reader, working fine from all other apps.
Thank you for the above hint with run script!
Calling foxit reader as a script, the pdf is displayed.
Now I need a hint how to get rid of the annoying pop-up pdf-architect invitation window, telling me, there’s no default pdf viewer and demanding another mouse click to close it.

BTW, there I found 24 entries “OpenWithPdfArchitect True” in my registry:
HKCU\Software\pdfforge\PDFCreator\Settings\ConversionProfiles{0-7}\OpenWithPdfArchitect Type=REG_SZ Daten=True -> False

HKU\HKEY_USERS\S-1-5-21-853582287-718305135-4051792412-1000\Software\pdfforge\PDFCreator\Settings\ConversionProfiles{0-7}\OpenWithPdfArchitect Type=REG_SZ Daten=False

HKU\HKEY_USERS\S-1-5-21-853582287-718305135-4051792412-1001\Software\pdfforge\PDFCreator\Settings\ConversionProfiles{0-7}\OpenWithPdfArchitect Type=REG_SZ Daten=False
which I changed to False, but that did not help.
What to do against the pop-up?

Hi Julian
My default pdf viewer is Adobe Reader and all other apps open this and yes, I did respond ‘no thanks’ to use PDF Architect. I tried reinstalling a couple of times with the same result. I then reinstalled an earlier version V2.4.1 and that works perfectly. I will stay with that version and maybe try a later one after V2.5.1 is updated.
Thank you for your response.


Did you leave the “open document” action enabled? If so, please disable it, this should get rid of the pop-ups.

We will try to fix this as soon as possible. We thought we’d fixed it, but unfortunately only for Windows 8 and not 10. Also, this bug is not so easy reproducible as I don’t have it here and can’t forced it.

Best regards

Any news on this? We’re still havine trouble…


this strongly depends on the OS and which application is the default. For a single type of file, you can work around it by using the “run script” action instead of the “open document” action. The problem is, the .NET method which we use to determine the correct default application is broken, which makes it very hard to find a reliable way to handle this in all supported Windows versions. We are still working on getting this to work more reliably.

Best regards,