COM Interface error with PdfCreator 1.3.2


I upgraded the PdfCreator 1.3.2, but when I ran my .NET application thats uses the pdfCreator COM interface, I got this error:

Retrieving the COM class factory for component with CLSID {40108C54-9352-46C9-822C-027727352F00} failed due to the following error: 80040154.

What I am doing wrong? I rebooted the pc after the upgrade and nothing happened.

Thanks in advanced.


Hi everybody, I have the exact same error, could someone help us please ?

The application I created works on the computer where I cretaed it but on other computer I got this error…


you have to recompile your application, or in the case of Excel, add the reference again, as the CLSID of the COM interface has changed.

kind regards,

Thanks for your answer philip.
By recompile your application what do you mean (english not my first language and I work with a french version of Visual Studio 12)

I also have a “Microsoft Excel 14.0 Object Library” reference.

And the error happens with this code :

    Private Sub load_sub() Handles Me.Load

        Dim parameters As String
        _PDFCreator = New PDFCreator.clsPDFCreator
        parameters = “/NoProcessingAtStartup”
        If _PDFCreator.cStart(parameters) = True Then
            _PDFCreator.cOption(“UseAutosave”) = 1
            _PDFCreator.cOption(“AutosaveFormat”) = 0
            _PDFCreator.cPrinterStop = False
        End If
    End Sub

I updated both computer with the last version of PDFCreator (1.6.2) and it’s now working.

But I’m wondering how can I do make my application working on a computer with another version of PDFCreator ?

Can someone please help me with this ?

It sounds like your service was built against ‘Any CPU’, causing you errors on 64-bit where you are using COM components. You need to build it for x86