COM Interface totally fails on Windows 7 64-bit;HELP!

PDFCreator is a 32 bit application. As a virtual printer application, it appears to work just fine on the 64 bit Windows platforms. However, the COM interface is failing miserably. very sad, because this is such an awesome product!

NOTE: PDFCreator works fine on Windows 7 32-bit. My issue seems exclusive to 64-bit.

I'm hoping you can help. I've tried both the 0.9.9 and the latest 1.0.0 preview. Same result. I've tried installing PDFCreator both ways (Stand Alone and Server) to not avail. Same result. My applications depend on this. Help, please!

Symptom: when my application runs, and attempts to create the pdfcreator.clsPDFCreator class object, I get the following error:

Run-time error '-2147024703 (800700c1)':
Automation error
%1 is not a valid Win32 application.

It seems the registered COM API build into the ActiveX server in PDFCreator.exe isn't exposed to other 32-bit applications on the Windows 64-bit platform. But !!!  ...that's not truely the case. The problem is within the PDFCreator.exe ActiveX server.

Here's the kicker!  If I happen to start PDFCreator from the start menu (causing the PDFCreator Printer Monitor window to display), then, my application is able to succeed in instantiating the clsPDFCreator object. Wierd, huh?  But, once my program calls the .cClose() method, the PDFCreator Printer Monitor window closes as the PDFCreator.exe process exits. Then, my application is back i nthe same position next time I try to print.

This situation can easily be reproduced using the COM\\VB6\\Sample1 program. It demonstrates the problem perfectly. Compile Sample.exe on a 32 bit version of windows. I compile from my Windows XP PC. Place the Sample1.exe on your Windows 7 64-bit PC which already has PDFCreator installed. And, try to run Sample1.exe. It will fail to run with the Run-time error I reported above.

Now, I've tried using the Windows 7 Control Panel | Programs and Features | Run Programs made for previous versions of Windows tool. This says it saves settings for PDFCreator.exe, but doesn't have any effect on my problem.

How do I enable the 32-bit COM interface exposed by PDFCreator when it's installed on a Windows 7 64-bit machine?

It has something to do with the vb6 reference to the ole automation. Open your project on a 64bit system and remove the reference to the ole automation . Than save and close the project. Open the project again and add a new reference to the ole automation. Than save and compile your project. Test it.
At the moment I have no other solution for you.

Humm. Interesting. "fix" my references to relate to whatever versions are on the 64-bit version of the OS.  Sounds like a cool idea. I'll give it a shot and post my results here. Hope this helps other developers out there as well.

Frank - you're a great guy. That's for the suggestion!