Combine files error pdf architect 2 create module

So i grabbed my list of pdfs to combine, and i get this. 

Message: Reference is not Dictionary In file: {hl}Advanced_PDF_Objects.cpp{hl=file:\\W:\TemporaryBuilds\2\151\Sources\
PDFL\src|oldcore\core\Advanced_PDF_Objects.cpp} In Function: Core::CPDF_DIctionary::Get_Dectionary In line:216

and it doesn’t make the pdf… what do i need to do?

so i went back and tried to combine groups of files, and it worked up to the 20th file, but wouldn’t combine the 21rst.  So i combined the 20 files, then combined that to the 21rst which worked, but the 22nd file keeps giving me that message. What does it mean?


I was not able to reproduce this problem here, were the files all PDFs and does it seem to be related to the number of files or is it always the same file(s) causing the error?

best regards,

I receive the same error message when I attempt to combine PDF files that were generated using LibreOffice’s built-in PDF export tool. I was trying to combine PDF files generated with LibreOffice Writer version If I generate the PDF files using the PDFCreator printer driver, the problem goes away. PDF files from other sources seem to work fine as well.


do you happen to know if LibreOffice uses ghostscript and if yes, which version?  Is it possible to combine these PDFs with the PDFCreator? We were having some issues with PDFs generated from ghostscript 9.15 but it might be something different, too.

best regards,

I’m afraid I don’t know which PDF engine LibreOffice uses. Files created using the PDFCreator print driver combine with no problems.


is it possible to combine the PDFs create with LibreOffice with the PDFCreator (print more than 1 printjob to the PDFCreator printer to activate the manage button which allows you to combine documents directly in PDFCreator)? If that also doesn’t work it is very likely there is a problem with how the PDFs are created from LibreOffice. Could you send 2 example PDFs created with Libre Office to We will investigate the situation. 

best regards

I was struggling with the same problem, but after reading these posts I solved it like this. Print the document that causes the problem to printer ‘pdf architect’ and save. I was able to combine this newly created document with other documents.