Crop still missing?

I’ve looked at other posts dating back several years and am astounded that an image crop function still doesn’t exist.

There’s even a button on the insert tab that says “Crop.” But it doesn’t crop. It doesn’t reduce the page size to the selected image… that’s what an actual Crop does. Frankly, I don’t know what this “Crop” does, though I’ve tried to use it for an hour.

Other posts tell me to use Snapshot. But snapshot just takes an image of a selected image at whatever the zoomed scale. There’s no consistency of scale, size, or resolution when I paste that image to a new file.

Why doesn’t Architect feature a real crop or actual scaling tools? These are pretty basic, and if they still don’t exist after several years?? I’ll be seeking a refund.


the crop function can be used on image objects inside the PDF. As you might have read in previous responses, a crop function for PDF is not, in any form, a basic feature. Due to the way a PDF is technically constructed, cropping is far more complex than it is for e.g. most image formats, since the PDF isn’t defined by pixel values but rather a complex construct of objects and references. Of course, if you purchased the software within the last 30 days you can get a full refund by contacting our payment processor upclick (

Best regards,


That’s not cropping, that’s clipping. A crop is a reduction of an image to a specific shape or size, which your program cannot currently do, although your marketing (and even the “cropping tool”) indicates it can.

And for the life of me, I can’t understand the function of Snapshot, which neither retains scale nor resolution of the image it captures. MS Paint can do something similar.

I’d encourage you to remove that language. It seems your technology has not caught up with your ambitions, and it certainly misled me and my purchase.


as said earlier, you can only apply cropping to individual images inside the PDF. I don’t mean clipping or reducing the PDF to 1 of the images, I mean performing a proper cropping operation on the image, as in " a reduction of an image to a specific shape ( in this case a rectangle) or size". It just isn’t possibe to perform a cropping operation on the entire PDF, but this is clearly stated in the feature list.

Best regards,


And what, pray tell, is the purpose of a “crop” that doesn’t actually crop the PDF?

Maybe I’d like my image to have a gigantic margin? Surely this is a useful function, and exactly what customers anticipate when you advertise a cropping function.

This is not actually useful at all. And it’s not clearly stated. If it was, we wouldn’t be having this exchange.

The only place the crop feature is mentioned/advertised at all is in the feature list overview, where it clearly states: “Include images; clip, crop and change image resolution”.


Sorry to jump into an old thread like this, but not having a crop function for PDF pages is preventing me from choosing PDF Architect for our business needs.

Have there not been new developments over the years which would make this function easier to implement?

Thanks for your reply.

Same here, sorry to drag one of the old ones up.

I am currently editing a pdf file but that has an image inside of it but i cant edit the image, i cant delete a certain portion of the image in pdf architect if the image is inside a pdf.

Wouldn't that be possible feature to add? to edit the underlying image in a pdf file?
I understand that you cant crop a real pdf file with real objects and all that, but if it is a scanned document that isn't OCR with the scanner but instead created as an image.


it should be possible to crop images inside the PDF, did it not work or did you not find the tool for it?

Best regards


Hi, my bad!

I started my reply with the mind in editing an image, i dont know why i posted it here as it has nothing to do with croping...

Croping works exactly as it should, so for anyone that are thinking about croping and that it does not exists, it does in version 6 and works perfect!
Editing an image, deleting portions of an image inside a pdf with PDFAr.. is however still a valid request.

@Ruizzie heads up for you at least!