EmailSmtp Settings Not Recognized

I have been experimenting with the COM interface settings from Microsoft Word with VBA. I have been able to 1) print a document to a PDF file, 2) Print a document to a PDF file and attach the PDF file to a email using the Email Client. However, when I try to 3) print a document to a PDF file and send as an attachment using the EmailSmtp settings I am getting a runtime error on each statement that includes the EmailSmtp settings defined in the documentation.

'Email client settings.
If bEmailWithClient Then
'These all work as described
.SetProfileSetting “EmailClientSettings.Enabled”, bEmailWithClient 'Enables the EmailClient action
.SetProfileSetting “EmailClientSettings.Recipients”, strRecipients 'Recipients separated with ;
.SetProfileSetting “EmailClientSettings.Subject”, strEmailSubj 'Subject line of the E-mail
.SetProfileSetting “EmailClientSettings.Content”, strEmailBody 'Body text of the E-mail
.SetProfileSetting “EmailClientSettings.AddSignature”, bEmailAddPDFSig
End If
'Email smtp settings
If bEmailWithSMTP Then
'Even though these settings are in the documentation, they aren’t recognized.
'All resulting in a Run Time Errors e.g., "The property “EmailSmpt.Enabled” does not exist!
.SetProfileSetting “EmailSmtp.Enabled”, bEmailWithSMTP
.SetProfileSetting “EmailSmtp.UserName”, UserName
.SetProfileSetting “EmailSmtp.Password”, ServerPW 'Password that is used to authenticate at the server
.SetProfileSetting “EmailSmtp.Port”, Port
'and so on

Can anyone suggest what I might be doing wrong? End If


not sure how I was able to overlook this, but the SMTP email settings seem to suffer the same problem the EmailClientSettings had last version. The proper name of the setting is Sorry for the toruble I will create a ticket to update the docs right now.

Best regards,



Thanks. Yes, that works and get me past the point of the run time error. Unfortunately, I have hit another snag. When the code executes, Word (the application I am working in) freezes in a continuous loop. I restarted Word and simply tried the same process through the PDFCreator printer user interface. I clicked on Actions>Send as Smtp Email>entered the settings and attempted to send the test message and PDFCreator returns “Could Not Authenticate as Serve”. Tried with my regular email account with same settings I use with OUTLOOK everyday and with my GMail account. No joy.

Any ideas?


Gmail is a bit of a problem there. It detects PDFCreator as an unsave application trying to access your account and blocks it. For this to work, you need to enable “access for less secure application” (

I hope this solves it.

No joy. Changed setting in Gmail and still get the “Could not authenticate at server” error. Too bad, this would be a really nice feature if it worked.

This is interesting. I’ve just tried this again and for me it is working.

I’ve set:
Port: 587
SSL: yes

I reported this issue to my mail server admin today after another failed attempt at 1602 (4:02 p.m.) and got back the following:

How delightful: Our logs show a connection attempt from your IP address at 1602. I know it’s yours because that IP passed another message from you to us just three minutes later.

Here is what the log says:

2017-02-27 13:01:59 [Worker_1] Error: Worker_1 accept_SSL to client failed IO::Socket::SSL=GLOB(0x494ca524)
(timeout: 5 s) : SSL wants a read first

SSL has rather stringent rules on what has to happen when.
Apparently, the current version of pdfforge’s pdfcreator violates those rules.

I relaxed a few parameters; please try again (and let us know when you did).
But even if this helps, pdfforge should look into this.

Sent another attempt at 1710. It also failed. Response from admin:

The error you see is likely a protocol error: pdfcreator sends before it should, or it doesn’t send even when it is expected to.


Yes, that seems to work here as well using port 587. Thanks.

For the Gmail account. I’ll report this to my other mail server admin and ask if I should try with a different port there.