Error 339: MSCOMCT2.OCX missing or not correctly registered


I have a computer here that is having this issue show in the screenshot


I already tried registering the component using cmd (run as admin on a non-admin account). Which gave me a message of it being succesfully registering, but alas printing still gives me the also shown error.

When I run the application as admin, there are no errors, but the user in question needs to print too. What can I do about this, i'm not going to let him print in admin mode.

Speficied PC is a Windows XP SP3 computer.

 It looks like you have a permissions problem.  If it works for an Admin user, but not a (regular) user, I'm guessing you mean the (regular) user does not have local admin permissions.  So try this:

Temporarily set the (regular) user as a local admin and try the application.  If it works, then this confirms that the problem is related to permissions.  I also have WinXP SP3 workstations with PDFCreator and it works fine for us with restricted user accounts, and I didn't have to do anything special that I can think of.

Also, try logging in with a totally different (regular) user account on the workstation and see if that user has the same problem or not.  Here you're testing whether the problem is profile related or not.  If it does *not* work for the alternate user, then the issue is not profile related.  It if *does* work, then the problem is likely profile related.  In that case, save any profile-specific files (My Docs, pics, IE favorites, etc.)  In fact, ZIP the profile folder up just in case.  Then delete the user's profile, reboot, and try logging in again.  Note that if the user has logged in, then you log in as an admin, you may not be able to delete their profile because Windows holds some file open, so you may have to do a fresh reboot before yo can delete that user's profile.


 I tried having another user login on the pc and tried creating a pdf again, but with the same error.

So the problem is not related to the specific users profile, since it does work on an administrator account the problem must indeed lie with permissions.

But how can I get the specified users account to work without making him an admin?