Error Printing .doc with PDFCreator


Hi experts!

I have installed PDFCreator v3.2.0, Windows 7 (64bits) and Office 2007.
I am trying to convert a .doc file into PDF with pdfcreator but when I select file the system opens the word but does nothing else.

I read in other blog post that the problem could be from the registry entries.
These are my registry entries:
--HKEY_CLASSES_ROOT.doc -> (Default) = Word.Document.8
--HKEY_CLASSES_ROOT\Word.Document.8\Shell\Printto\command -> (Default) = "C:\Program Files (x86)\Microsoft Office\Office12\WINWORD.EXE" /n /dde

I tried to change this last entry by:
a) "C:\Program Files (x86)\Microsoft Office\Office12\WINWORD.EXE" /q "%1" /j "%2" -> But it does not work. Word say me: "PDFCreator.doc file cannot be found"
b) "C:\Program Files (x86)\Microsoft Office\Office12\WINWORD.EXE" /j "%1" /q "%2" -> But it does not work. Word say me the same

I am desperate. I tried multiple combinations of different parameters. You could help me?

Thank you very much in advance.



your registry edit basically looks good, the remaining question is:
Which command does office 2007 actually use for printing, are these the correct parameters?
Unfortunately there doesn't seem to be any official documentation on this, so I can only suggest to install LibreOffice or contact MS about this.
PDFCreator will only execute the specified command providing the filename and default PDFCreator printer name as input.

Best regards



Hi Robin.

Thank you very much for the quick answer.
I do not know what are the correct parameters for the 2007 office :frowning:
I have found this documentation on the internet:

The /dde parameter that I have in my registry does not appear. wow!

I tried another computer(friend) with Windows 10, Office 2010 and PDFCreator 3.2.0 and this is the entry that appears in the registry:
"C:\Program Files (x86)\Microsoft Office\Office15\WINWORD.EXE" /j "%1" "%2"

And it works perfectly! But in my computer with Windows 7 and Office 2007 there is no way to work. I tried to copy the same parameters but it does not work either :frowning:

Any help or suggestion will be welcome.



yes DDE is supposed to be deprecated since Windows XP but I have seen even current office editions still using this. Unfortunately, PDFCreator can't handle the DDE command, since we don't support Windows XP any longer and in theory applications shouldn't be using DDE in later Windows versions.
You could try using the "print" instead of the "printto" entry and have PDFCreator set itself as default printer on the fly.
Reinstalling office from the most recent source might also solve the problem, but I haven't tried this myself.

Best regards



Hi Robin,

Thanks for your support.
I do not know how to use the "print" entry instead of the "print to" entry. Could you give me an example?
On the other hand I updated the Office version from 2003 to 2007 recently and now I can't reinstall Office. Office 2003 did not work either and I thought that updating would work.

Best regards.



first I should point out, if you don't convert a large amount of files every day, you can always still open them in Word and print them to the PDFCreator printer from there.
I also noticed my value for HKEY_CLASSES_ROOT\Word.Document.8\Shell\Printto\command is slightly different than yours, try using "C:\Program Files (x86)\Microsoft Office\Root\Office16\WINWORD.EXE" /j "%1" "%2" (without the /q)
If you want to try first using "print" instead of "printto", best create a backup of that key, in case anything gets more broken than it currently is.
Then check the command for HKEY_CLASSES_ROOT\Word.Document.8\Shell\Print\command and if this has a dde command, try replacing it with"C:\Program Files (x86)\Microsoft Office\Root\Office12\WINWORD.EXE" /i "%1"
You might additionally need to delete the "printto" key afterwards as PDFCreator will always try to use "printto" first, if it finds any entry for it.

Best regards