Fail to print all word documents with pdf creator 1.3.1


I have an issue who happen with all words document (office 2010) I use the following macro who works perfectly with PDFCreator-1_2_3 and always fails with PDFCreator-1_3_1

The problem happen after pdfjob.cPrinterStop PdfCreator process is "Frozen"

Can anybody try it please?

Thanks by advance


Here is the macro:

Sub DoIt()
Set pdfjob = CreateObject("PDFCreator.clsPDFCreator")
NomPdf = "test.pdf"
With pdfjob
If .cstart("/NoProcessingAtStartup") = False Then
MsgBox "Can't initialize PDFCreator.", vbCritical + vbOKOnly, "PrtPDFCreator"
Exit Sub
End If
.cOption("UseAutosave") = 1
.cOption("UseAutosaveDirectory") = 1
.cOption("AutosaveDirectory") = "c:\\"
.cOption("AutosaveFilename") = NomPdf
.cOption("AutosaveFormat") = 0

End With
Application.ActivePrinter = "PDFCreator"
ActiveDocument.PrintOut copies:=1
Do Until pdfjob.cCountOfPrintjobs = 1
pdfjob.cPrinterStop = False
Do Until pdfjob.cCountOfPrintjobs = 0
With pdfjob
.cDefaultprinter = DefaultPrinter
End With
Set pdfjob = Nothing

End Sub


Hello Philip,

I have just downloaded the release  1.3.2 and I confirm it works now,The postcript file was around 3.2Mo and it prints correctly and quickly.

Good work! Many thanks for your quick support.

and thanks for this good Product!



I think that this is an issue with the file size. We have "added" a bug in 1.3.0 which causes PDFCreator to become really slow with large files. This will be fixed in 1.3.2 which we will release later today. Please give that version a try.

kind regards,

 I believe from what I have read in other posts and what I have expienced my self in running pdfcreator that this is a issue with in the 1.3.0 and 1.3.1 version. I run through a php com object similar to your script that the windows pdfcreator process that gets launched never terminates after the first job goes through. I was unable to find a solution except to downgrade back to 1.2.3 and hope they come up with a fix to this issue. 

Yes I am sure something is wrong

I hope they will fix it, If a developper is reading this post please have a look...try this quick macro with Microsoft Word 2010

like you I downgrade to 1.2.3 and it works perfectly.

I think the following post is around the same issue :