How to merge multiple prints?


Even after following the instructions on the support page I can’t get it to work.

Here’s a rundown of what I do and what happens:

  1. I print a document using the PDFCreator printer
  2. I get the “PDFCreator 2.5” popup asking me to change settings and a Job window (with title, subjet, keywords, etc.)
  3. I close the settings popup
  4. I print another document using the PDFCreator printer
  5. I get the settings popup again (I believe this is were things go wrong)
  6. Previous Job window is unchanged. If I click the “merge” button there’s only my first print job there.

And, on top of that, if I cancel this Job window (using the cancel button) and try to print something else, I get the settings popup AGAIN and a Job window telling me there’s one document waiting. And yes, if I click the merge button there, I see the 2nd document I tried to print, as well as the third one.

I think the settings popup mess things up. Unfortunately, it keep showing up EVERYTIME I do something related to PDFCreator. I already uninstalled/reboot/reinstalled PDFCreator, which didn’t change anything. I also tried going through every setting pages clicking “Save” on all of them, still didn’t change anything.

PDFCreator v.2.5

Hey @CleyFaye,

Could you please provide the version of your pdfcmon.dll.

You can find the .dll it at C:\Windows\System32
Right click the file and then go to properties -> details.

Best Regards!

It says version

Also, “Copyright © 2011, 2012, 2013”, so I’m assuming it’s part of the problem :frowning:

With that piece of info, i uninstalled pdfcreator again and checked that file which was now gone. After reinstallation it did bump to version

I’ll assume something’s gone wrong during the update from the previous version. The procedure was roughly:

  • Uninstall PDFCreator 1.5 (not sur of the exact version, only that it was 1.x)
  • Uninstaller asks to reboot, so I reboot
  • Installation of PDFCreator 2.5
  • Issues
  • Uninstall PDFCreator 2.5, uninstaller asks to reboot, so I reboot
  • Installation of PDFCreator 2.5
  • Still have issues
  • Check pdfcmon.dll version, see problem
  • again uninstall PDFCreator 2.5. This time the installer don’t ask for a reboot at all
  • again Reinstall, not asked for a reboot

Aaaaand problem fixed.
That file was not removed the first few uninstall rounds for whatever reason. I’m glad it fixed the issue on my end to know this though.

1 Like

You’re right the pdfcmon.dll is the issue.

This is usually fixed with one reinstall, but I guess sometimes windows needs to learn the hard way. :smile: