Impossible to delete documents from the pdf creator queue



I'm using PDF Creator 0.9.8 release, and i've a problem that i cannot solve. Some documents are queuing in the pdf creator spool and i can't delete them. when selected and deleted, they disappear for a short moment and are displayed again.

I tried to delete them from system directory  C:\\Documents and Settings\\username\\Local Settings\\Temp\\PDFCreator\\PDFCreatorSpool but that operation is ineffective. I'm told that the files are already used by another application even if uninstall pdf creator  off the system.

Could someone help me ? 

System : Win Xp Pro - Standard Installation -

Best regards.



I have the exact same problem with the 0.9.8 release. After every PDF print job, PDF Creator re-queues this print job along with every previous print job and none of these print jobs can be deleted.

I have to kill the PDFCreator process to stop the pop-ups (temporarily, until the next PDF print job).

System: WIndows Vista Ultimate (64-bit)


I am having the same problem.  Did you find a fix?

I also have such a problem in 0.9.9.

I can’t delete the jobs out of the print queu.
I made two documents, combined them and I got a third one.
When I printed the third one all three wer in the queu.
Only the third job I could delete.

System: Vista, PDF Creator 0.9.9

Go to my computer…
C:\Program Files (x86)\PDFCreator\Temp\

Right click on :


I unchecked read only and edited permissions under the security tab.

If you click advanced, you may be able to get away with telling it only things under this directory, but since I’m the only user, I just said full control and left it at that.

the solution:

via commandline

pdfcreator.exe /CLEARCACHE

deletes all printjobs in the queue.


None of the above worked for me but this did:

To stop the temporary file error / PDF printer queue not deleting

Temp files apear to be stored in:
Documents and Settings\\(User name)\\Local Settings\\Temp\\PDFCreator\\PDFCreatorSpool

The problem lies with ownership of this directory, which will also stop you manually deleting the spool files.

1) Take ownership:

Run Windows Explorer
>Folder options
>View Tab
>Scroll to bottom to Use simple file sharing (Recommended)
>Turn it off

2) Right click on the above directory PDFCreatroSpool

Allow access to all actions for all users (this is probably overkill but gets the job done)

3) Then just reverse the Windows Explorer steps above to turn Simple file sharing back on.

Worked for me after much frustration.

I think this problem arrived with an XP upgrade but can't be sure.