Internet Explorer: change default pdf viewer from PDF Architect to Adobe Reader

Internet Explorer: change default pdf viewer from PDF Architect to Adobe Reader


I recently installed PDF Architect 4, as a stand-alone install (not as part of a PDF Creator install), on a Win 7 Pro 64 bit machine. After doing so, PDF Architect has replaced Adobe Reader as the default application for opening PDFs in Internet Explorer.


This problem applies only to IE. Double clicking on a pdf in Windows Explorer invokes Adobe Reader.

I’ve disabled the PDF Architect 4 Toolbar and Helper add-ons.

PDF Architect 4 does not appear in the Uninstall a Program list, so I can’t run the Setup Manager.

Internet Options / Programs / Set Programs:

Associate a file type or protocol with a program: .pdf is set to Adobe Reader.

Set your default programs:

Adobe Reader is not on the list.

PDF Architect 4 has 0 defaults.

I tried installing PDF Architect as part of a PDF Creator install, but it installed PDF Architect in a different folder (Program Files (x86) instead of Program Files), and didn’t solve the problem.

I tried uninstalling PDF Creator and deleting the PDF Architect folder and shortcuts, then re-installing PDF Creator and PDF Architect. Not only did that not solve the problem, but it didn’t create any shortcuts for PDF Architect.

 Any ideas would be greatly appreciated.



I could imagine it is still listed in IE, but not in the default view.
The default view for configuring addons in IE is set to “currently loaded addons”.
The “currently loaded addons” list however somehow doesn’t contain the “run without permission” addons (even if they are currently loaded) please try switching to that view and deselecting any remaining PDF Architect entries. If this doesn’t help, you could run the standalone installer again. This will recognize the exisiting PDF Architect installation and offer the option to modify it.
We are still trying to find out, why no uninstall entry is created in some cases; this isn’t reproducible on any of the test machines and only seems to happen under certain conditions, so far it is a big mistery.

best regards,

Thanks Robin. It's now fixed.

I disabled PDF Architect 4 ActiveDoc Class from the Run Without Permission add-ons, but that didn't help. I then attempted to run the stand-alone installer, but it said the program was already installed.

I fixed the problem using the following steps:

  • Using Glary Utilities Uninstall Manager, uninstall the 10 PDF Architect modules that it found.
  • Install PDF Architect using the stand-alone installer.
  • PDF Architect was now in the Uninstall a Program list, allowing me to deselect Internet Browsers Integration in the Setup Manager.

Thanks for your help, Robin.