It does not generate a file, if a choose as a printer in any software

when I try to generate a PDF file using the print option, is not generated. In any program

There is a parameter that could be moved?


please set the logging level to debug in the debug section of the application settings.
Now send a print job to the PDFCreator, afterwards restart it and sned us the resulting logfile.
Otherwise we will not be able to tell why it is not working on your system.

best regards,

Hi all,

same here after updating to version 2.0 from 1.7.3.
I get no message but also no file to save.
De- and reinstalling, downgrading to 1.7.3 doesn’t help.

Logfile says (error and debug mode):
2014-12-16 13:30:21.5636 [Error] pdfforge.PDFCreator.App.App_OnStartup: No file in InfoDataFile argument or file does not exist.

Any help welcome,

pdf creator testpage is working.
windows testpage is creating a .ps file in AppData\Local\Temp\PdfCreator\Spool but no save dialog is following.

SOLVED! (for me)

i had tried to set the security settings for the folder AppData\Local\Temp\PdfCreator\.
First i had to own it, then i set the full control for my user.
Still no saving dialog.
Later on i added the “SYSTEM” and set it to full control. After this printing and saving is working fine again.

Thank you.


if this was the problem, it was most likely caused by incorrect permission for the AppData\Local\Temp folder. which then get passed on to all folders created below it. If you are using a version of PDFCreator <2.0.1 please check set the correct permissions for the temp fodler, otherwise the PDFCreator\spool folder will get created with bad permissions everytime you restart PDFCreator.

best regards,


I have been using PDFCreator for years and appreciate very much.
However, sine recently, the problem described above started appearing on one of my PC (Windows 7 SP1, thoroughly maintained as my other PCs)
Could you be more explicit on what the permissions should be for:
and on the way to set them
Is it normal that no permission is set for
%USERPROFILE%\AppData\local\temp ?
Best regards

Hello again,

it seems the problem is solved for me. Here is what I found after investigation and what I did:

- there were no permissions set on folder %USERPROFILE%\AppData\local\temp , while every other subfolders of %USERPROFILE%\AppData\local\ seemed to have the same permissions as parent forder %USERPROFILE%\AppData\local

- I then looked for a way to set the same permissions on %USERPROFILE%\AppData\local\temp as for others,

- for that:
 + I ran cmd with administrators right*
 + I passed the command icACLs “%USERPROFILE%\AppData\local” /save Perms.txt
 + In the first line of Perms text, I replaced “local” (i.e. the name of folder from which the permissions where copied) by “temp” (i.e. the name of the folder to which I wanted to grant same permissions), and then saved the file.
 + I ran the command icACLs “%USERPROFILE%\AppData\local” /restore Perms.txt

For the time being, PDFCreator is working fine again, despite several reboots.