Need to run PDFCreator in the background when exporting data to PDF


In my application am using PDFCreator tool to create/export data to PDF. But for my requirement when i export to PDF i shouldnot get POP-UP to save the file(It should happen in the background). So for that i have added the registry as below:

REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Print\Monitors\PDFCreator\Ports\PDFCreator /v Arguments /t REG_SZ /d "-PPDFCREATORPRINTER -OPTIONSFILE"%SystemDrive%\Program Files\PDFCreator\PDFCreator.ini "" /f

REG ADD "HKLM\SOFTWARE\PDFCreator\Program" /v UpdateInterval /t REG_SZ /d "0" /f

but still am getting the POP-UP. I wanted it to run in the background when am exporting data to PDF. But the above reg addition is working in Windows 7 but not in Windows 10.

So i need to disable that POP-UP(or UI) to export the data into PDF ( The default save directory i have added in PDFCreator.ini file.

It would be great if someone help me.



Hi Mike,

did you try to set an automatic profile as the default for the printer you'd like to use.
More information:

Hi Thanks for your reply.

Yes i have configured the below settings in the pdfforge.reg file under: