No automated printout without user intervention after automated storage of the PDF

My Problem: I use automated storage of the PDF files and automated printing to an IPP-printer for producing the PDFs for document management and the printouts for (i.e. bills) customers in high numbers. But instead of printing without any user intervention the user has to select the printer for each single printout.

This works fine with version 0.9.9 (but only for black 'n white printing) -

Since Version 1.0.0 it results in this problem ('cause colored printing is wanted!).

Is there any approach to a solution of this problem?

Hi DeveloperMan

thanx for your reply: Yes, your absolutly right! But the problem I once postet in the discussion group was solved with version 0.9.9 and , as far as I've seen my problem-log, it had a different symptom and reason. With the newer Versions you find no wrong or error entry in the log, because you don't come to the correct sequents of events (printer dialog for choice of the printer) at all.

Seems there is a wrong call of routine for user intervention at this point in the program.

So I hope there will be a new, corrected release of PDF-Creator.

To the program-developers:

How do the developer of the PDF-Creator comment this problem?

With Version 1.0.2 the function 'Printing' with the options 'Print after Storage' and 'User intervention' set to OFF(standard) including the printer path does not work any more, that means instead of printing directly to the appropriate printer the printer dialogbox appears with the default printer of windows.

Anybody who experienced the same? Is there a solution or will there be a new version of PDFCreator where this failfunction is corrected?


Sorry, but you're wrong! These are all functions within PDF-Creator and as mentioned at the beginning of this posting, I already checked the Auto-save box as well as the Printing box.

But for a better understanding: is it possible to post a little screen shot?

 and by the way: same settings within version 0.9.9 result in a correct behavior of the PDF-Creator (but only with Black'nWhite printout). Not so in version 1.0.2 ,which I use for color PDF's and printing.

Perhaps a short discription of my configuration:

Default printer is PDF-Creator (printer) -  because the application (bookkeeping software) uses the default printer.

In the PDF-Creator (programm) the auto-save box is checkt (with storage path) and after that the printer box is checkt with 'no user intervention' and direkted to the unc path of the network-printer as installed in the windows(xp) printer management.

With this settings I expect a PDF creation in the appropriate storage path ( which works correct) and after that a printout on the appropriate networkprinter (where I now receive a check dialogbox from the printermanger (windows) to select a printer for output, offering the PDF-printer as the default printer instead of printing directly, as configured in setup of the PDF-Creator)

By the way: I installed and deinstalled the PDF-Creator now a several times an different workstations completely without success.

It seems, that the Setting for direct printing without intervention is completely ignored.

I think I see what you are doing now, you're using Auto-Save with the "Print after saving" option on a network printer.  

I have the exact same problem when I have Query User set to Off.  I guess you can't use the network printer as your default because your bookkeeping software needs PDFcreator as the default.  This does look like it is a bug in the software. 


Soem people in the discussion

have the same problem, but that solution for it wasn't helping everyone.  Also, it looks like you had already seen that dicussion.

I tried editing my comment, and apparently it didn't work like I expected.  Try reply #3. 

It sounds like you're using a function I'm not familiar with, so I'm assuming that you're using a different program to print documents using PDFCreator.  

If you have to select a printer each time, is probably not a problem with PDFCreator, since it acts like a printer.  If you have to select a file name each time, make sure you're using Auto-Save.  Open up PDFCreator, then go to Printer and Options.  Make sure the Auto-Save box is checked.  

Hallo Frank

I found the reason (and solved this problem):

This problem only occurs when using network printers which - when created - use their unc-path in its printer name (this is for example NDPS-printers and IPP-printers within Novell) and you can't change the printer names (becaus automaticly named by the installation procedure)! Seems that PDF-Creator (and not only this programm) has a problem with blanks and special typings like back-slash.

But if you install a printer (after having installed i.e. an IPP-printer - with the access ipp path in the port definition) as local printer und you use this port-path when defining the printer port, you are able to give this printer a normal name as always.

Then this problem is no longer occuring!

Best regards