No PDF Creator printer installed after 2.3 install

I have just upgraded to 2.3.
I ran fine 2.2 with printer created.
During installation process everthing has been desinstalled successfully including PDF printer.
After 2.3 install process I got a message that not all PDF printers have been installed. Please check blablabla…

Only PDF Architect printer exists.

Any clue ?




most likely there was a problem replacing the printer during the update becasue one of the files which needed replacment was still in use by another application. Please try if uninstalling/rebooting/reinstalling solves the issue. If not, please let us know and we will look at this in detail.

Best regards,



Thank you for your help.

I have already done this before posting in forum.

I did desinstall the whole kit (PDF Creator+ Architect), including PDF Architect printer that was created successfully.

Then rebooted.

Then tried re-install but with the same issue…

As a matter of fact Windows 10 Tuesday fixes run during thus night…As a clue ?

Sorry not to have better informations.



fortunately there are some tools that come with PDFCreator which can be used to debug/fix the printer issue.
Please try the following: run cmd. exe and navigate to the PDFCreator folder. There, run
printerhelper.exe /uninstallprinter
Next, run
printerhelper.exe /installprinter PDFCreator /Portapplication=“path to your PDFCreator.exe”

One of the commands should give an error indicating the cause of the problem, please post the error here.

Best regards,


D:\Program Files\PDFCreator>PrinterHelper.exe /uninstallprinter
Message = La référence d’objet n’est pas définie à une instance d’un objet.
Source = PrinterHelper
StackTrace = à pdfforge.PrinterHelper.Win32Printer.GetMonitor(String portName, String& monitorName)
à pdfforge.PrinterHelper.Win32Printer.GetPrinters(PrinterEnumFlags printerEnumFlags, String monitorName)
à pdfforge.PrinterHelper.Printer.UnInstallPrinter(IWin32Printer win32Printer, String driverName, String monitorName, ILogging logging)
à pdfforge.PrinterHelper.Commands.CheckCommandUnInstallPrinterAndExecute(IDictionary2 cmdlParams, IWin32Printer win32Printer, String driverName, String monitorName, ILogging logging) à pdfforge.PrinterHelper.Program.Run(IDictionary2 cmdlParams, ICommands commands, IWin32Printer win32Printer, ILogging logging)
à pdfforge.PrinterHelper.Program.Main(String[] args)
TargetSite = Boolean GetMonitor(System.String, System.String ByRef)

D:\Program Files\PDFCreator>printerhelper.exe /installprinter PDFCreator /Portapplication=“D:\Program Files\PDFCreator”
Error: Found invalid command(s):
portapplication=d:\program files\pdfcreator

Hope that helps…?


I do have tried other syntax:

D:\Program Files\PDFCreator>“D:\Program Files\PDFCreator\PrinterHelper.exe” /InstallPrinter PDFCreator PDF.test /PortApplication “D:\Program Files\PDFCreator\PDFCreator.exe”
Error: Printer port already installed. Uninstall the port before you use the command ‘AddPrinter’.

OK finally I did succeed install the printer.
The problem was that pdfcmon port was left from another installation process.
What I did was under regedit I physically deleted the port pdfcmon in :


I did reboot
Then reissue the same command that indeed succeeded.

Thank you for your help.


1 Like

Dear Jean-Philippe,
Thank you very much for posting the solution to this issue that had annoyed me too. It is working again!