No PDFCreator dialog for non-admin user


#1

On one of our computers, if you run PDFCreator from the Print dialog of any application, there is no dialog box to prompt you to save. The two files are created in C:\Users\username\AppData\local\Temp\PDFCreator\spool as you would expect, but nothing then processes the files.

Things I have tried:

  1. Ran PDFCreator logged in as administrator. This works, but is obviously not a viable solution.
  2. Reinstalled logged on as administrator.
  3. Reinstalled logged on as non-admin user (entering admin credentials when asked).
  4. Tried an old version (2.2). This does not work.
  5. Rebooted between uninstall and reinstall.
  6. Checked permissions on C:\Users\username\AppData\Loacl\Temp\PDFCreator\spool. They are open for the user and for SYSTEM. I've now opened it up to Everyone.
  7. Checked that pdfcmon.dll was removed between uninstall and reinstall.
  8. Checked that no unused ports on the "printer" setup have been left from previous installs.
  9. Checked the installation log. It shows a successful installation.
  10. Checked the execution log file, with logging level to "Trace". There is a full log from an admin user and no record of activity from the non-admin user.
  11. Checked permissions on pdfcmin.dll. These match other similar DLLs in system32.
  12. Tried Print PDFCreator Test page - this works. Tried Print Windows Test page. This fails.
  13. Put the non-admin user into the Administrators built-in Windows group. This did not work (I was expecting it to work, to be honest).
  14. Installed the same software on a similar computer. It worked as a non-admin user.
  15. Checked that the Print Spooler is running and that normal printing works.
  16. Tried logging in as a different non-admin user who had not previously used that computer (and so had a clean registry).

This computer, which is for a finance person, has taken a long time to set up, so I am reluctant to reinstall the OS and build up from scratch.

Running Windows 7 and PDFCreator 3.4.0.

Any suggestions will be gratefully received.


#2

Hi,

thanks for the detailed report and sorry for the trouble.
It does sound like an issue with the permissions at first, but since you already checked those I am not really sure what could be causing this. The PDFCreator test page doesn't go though spooling but just converts a preconfigured Postscript page with the selected profiles settings, while the Windows test page is actually printed to the PDFCreator printer. Do the jobs start processing, if you print them with a non admin user and then have him run the PDFCreator.exe by hand?
To enable logging for the pdfcmon.dll, add the following DWORD (32 bit) value to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors\pdfcmon in your registry: name : Logging, value :1. This will cause PDFCreator to create an advanced logfile at %Windir%\Temp\_pdfcmonLog.txt which might help to find the cause of the issue.

Best regards

Robin


#3

Thank you! Turning on logging was the key to the whole thing.

The solution in the end was:

  1. Turned on pdfcmon logging (see email below). This caused the PDFCreator
    dialog box to open, which it hadn't done before. After clicking Save, I got an error
    message (“Failed to check launch permissions. Failed to communicate with
    Windows service to check PDF Architect 6 – MDI-APP application data. Class
    not registered”). It looked like a problem with the installation of PDFArchitect.

  2. Uninstalled PDF Architect.

It all works perfectly now!