Non-ascii characters in path

PDFcreator 2.1.2 cannot print pdf file when there are non-ASCII characters in path to user temp dir. c:\user\xyz\appdata\local\temp - in my case in place of xyz there’s “bąkl”.
As you can see below it replaces “ą” with “b\304\205” and it does not work.

Error is:
2015-09-21 11:32:44.4849 [Error] pdfforge.PDFCreator.Core.Jobs.GhostscriptJob.RunJobWork: Ghostscript execution failed: Error: /undefinedfilename in (C:\\Users\\b\304\205kl\\AppData\\Local\\Temp\\PDFCreator\\Spool\\
Operand stack:
Execution stack:
%interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push
Dictionary stack:
–dict:1223/1684(ro)(G)-- --dict:0/20(G)-- --dict:78/200(L)–
Current allocation mode is local
Last OS error: No such file or directory
2015-09-21 11:32:44.4849 [Error] pdfforge.PDFCreator.Core.Jobs.AbstractJob.RunJob: Executing Ghostscript failed


yes I am afraid this is a problem with Ghostscript 9.16 which we only noticed after the release.
You can either revert to PDFCreator 2.1.1 (uses Ghostscript 9.14) or manually replace the ghostscript in the PDFCreator folder with GS 9.14 (32 bit version).

best regards,

Ok, then I’ll stick with 2.1.1 on other pc’s and on this one I’ve changed user profile path.


That of course is also a valid option, just didn’t want to recommend it:)

best regards,

Well, I know. I’ve changed the profile path from “bąkl” to “bakl”, at least one program stopped working so I’ve created symlink bąkl -> bakl . Fortunately mklink /D exists.
Downgrade is a better solution, you’re right (: