Not saving changes

I'm having a little difficulty, I have an existing PDF document. One of the pages needed a signature, I printed this page, scanned it, and now wish to re-insert the page (saved as a PDF as it happens). This part is fine....

I can insert the page without problem, and the document looks correct scanning through (page appears in the correct place etc). However, I cannot seem to save the changes. I have pressed 'save', and then closed the document, on opening, the inserted page is missing. I then tried re-inserting and 'save as' under a different name. The page is still missing on opening (I have the fully paid version).

I did ask a question of support, but was simply sent a link to the user guide.


OS: Windows 7

PDF Architect V



do the documents contain personal information or would you be willing to send us those to do some testing? I couldn´t reproduce this here, inserting page and saving that change worked fine.
Did you insert it at the top/bottom or in between?



I can send them, where is the best place to do so? It’s a flyer so it was more 'floating’

many thanks


you can send them to .
Have you updated to version 1.2.97?

best regards,