Object synchronization method was called from an unsynchronized block of code

Windows 7 32bits updated.

PDFCreator 2.1.2

We have this error using Autosaving but the report is saved OK.

Object synchronization method was called from an unsynchronized block of code.
System.ApplicationException: Object synchronization method was called from an unsynchronized blcok of code.
at System.Threading.Mutex.ReleaseMutex()
at pdfforge.PDFCreator.Utilities.Communication.PipeServer.Stop()
at pdfforge.PDFCreator.Threading.ThreadManager.Shutdonw(Application app)
at pdfforge.PDFCreator.App.RunApplication(String[] commandLIneArguments)
at pdfforge.PDFCreator.App.App_OnStartup(Object sender StartupEventArgs e)

I have the same error.

Whats the solution ?

Me too, Same Error.

Win 7 64bit 
PDF Creator 2.1.2

i search for a solution. 


we are still trying to find out what is causing this, do you get this for every print job or only some of the time?

best regards,

There is a blog which deals with this “unsynchronized block of code” issue in general terms. http://bbellomo.blogspot.com/2007/03/object-synchronization-method-was.html. The blog writer concludes: “I gave up on Google and went back to my code, and the answer was really simple. All I did was release the Mutex before I acquired it (I left out the line of code Mutex.WaitOne).” 

And he says: "What it [the error message] should say is “Invalid Object synchronization method called from an unsynchronized block of code” 

I am experiencing this error with PDF Creator on Windows XP SP3. I uninstalled, rebooted, ran ccleaner, rebooted and then reinstalled. I printed some contact sheets from Irfanview with no problems. Then I tried printing from Excel and the errors returned. While it did not print, when I opened PDF Creator from the start menu, the “save as” diaglogue re-opened, so the print job was still in the queue. But still it never created the PDF. I kept having to restart PDFC. After about 5 times, finally it saved.

Any hints on how to solve this issue? I have the same error an a Win7 / 64bit computer.
The error does not always happen. But sometimes it happens when printing from MS Excel.
It did happen when I started pdfCreator the first time after installation. Then I tried again and it worked for several days without error. Today it failed again, but still created the pdf file.


there probably isn’t a way to solve this from user end, We have already found a possible solution which will be included with the next PDFCreator release.

best regards,

The error message has gone away with version 2.2, but the symptom of saving, and then the dialogue box disappearing without the document being “printed” is still there. Should I open a new thread?

Per my previous post, when I try to save it prompts for  the file name, shows the 0% to 100% progress indicator, and then disappears without the file being created. If I open PDF Creator, the setting dialogue appears AND the “save” dialogue re-appears prompting me to save again.Sometime it disappears again and it takes a few tries.

this time i tried more than 10 times to save by opening PDF creator. Eventually after a system restart, I opened PDF creator again, the save dialogue also opened, and the file was actually created. Very frustrating.

I don’t know if it is a coincidence, but when I tried to print a Word file with a watermark, I’d get the problems described above, while if I deleted the watermark, that file would save as PDF. Then when I open PDF creator, other file with the watermark would again prompt to save, meaning it had remained in the pdf printer spool. What puzzles me is why it is inconsistent, perhaps it is a coincidence.

EDIT: I think it must be a coincidence. For the last few minutes all my documents have been printing.

as this thread is no longer receiving attention I shall start a new one with the same subject.


sorry about this, things started to suddenly pile up here and we will try to answer everything as quickly as possible, but starting a new thread was a good idea in any case.

best regards,