Obligatory Auto-Rotate - We need "No rotate" option

I have a major problem here that no setting can solve.

Every time that I combine two documents that have Portrait AND Landscape pages inside, the Auto Rotate always force them to all be the same setting: portrait OR landscape. If I set portrait, it won’t work for me, because it will rotate pages that shouldn’t be rotated. The same goes when set landscape… (as much as auto-detect/auto-rotate that doesn’t work properly)

So, there’s no option to ignore orientation of the pages and respect the original orientation…

We need this option!

The lack of this option forces me to rotate pages manually after print, because PDF Creator put them all in the same orientation.

PDFCreator should, definitively, have an option to respect the original orientation (to allow mix portrait and landscape when printing files with different orientation).


the problem with this is, in order to maintain the original orientation, the orientation needs to get detected correctly in the first place. The “automatic” setting is supposed to do exactly this, but sometimes fails. As you say it fails every time you combine documents with different orientations, it does sound like a potential bug and we will look into this. If you installed PDF Architect together with PDFCreator and activated the create module, you could alternatively use the virtual PDF Architect printer / merging functions for combining documents with mixed orientations, it generally seems to perform better at getting the orientation right.

Best regards

Thank you. I face this problem A LOT since I daily deal with electronic judicial court.

Everything need to be sent in PDF format (sometimes PDF/a)… and I often combine documents with different orientation to help judges to see certain scanned documents (landscape orientation).

I’m really looking foward to see this combined orientation fixed. Thank you.

Best regards.