"One Job Waiting" Everytime i try Print a PDF - PDF Jobs stuck in Queue

Hello All,
I just upgraded my Windows XP SP3 and Win 7 SP1 Workstations to  PDFCreator 2.3 from a previous version 2.x.x. Since I upgraded to the latest version 2.3 I am unable to print PDF’s without it being stuck in the Queue.

Whenever I try to PDF a document and go File > Print > PDFCreator select save then choose where I want to save the PDF nothing happens. If I try Print back that same document by going to File > Print > PDFCreator again the PDFCreator window comes up and shows One Job Waiting then when I click save it asks me to save the document two times but only one document is saved (sometimes nothing is created) and then the PDF comes up in Adobe Reader DC as usual.
It would seem If I am trying to PDF a document I have to do it twice to get a result, I am unsure what could be causing this problem because everything works fine before the upgrade.

PDFCreator 1.7.3 works fine no issues.
I have since reverted (downgraded) to PDFCreator 1.7.3 to get some work done until I can figure out what could be the problem. If anyone can help me solve this issue it would be greatly appreciated

Thanks in advance.

Hi,

I am afraid we haven’t seen this before and don’t know what could be causing it, but we will gladly help you with troubleshooting if you could install version 2.3.0 again, go to the application settings and set the logging level to trace, then start a print job and send us the resulting logfile to support(at)pdfforge(dot)org.

best regards,

Hey Robin Thanks much for the reply,

I will do as you instructed and follow up with a post as soon as I email the logs.
Thanks again

Just sent email set with Logs.

Regards.

Hi,

thanks I received it and had a quick look at it myself, but needed to forward it to our developers for a full review, so it might take some time.

best regards,

OK Thanks much
Really appreciate it, keep me posted.

Best Regards
Humps

I Updated to version 2.3.1 and i still have the same problem so i reverted to 2.2.2 which is working fine.

Another user is reporting a similiar issue here: PDFCreator printing stay in spool with message 'Waiting'

Patiently waiting for a fix…
Best Regards

Hi,

we found a problem causing this in version 2.3.0 but it shouldn’t happen in version 2.3.1 anymore, for most users the problem disappeeared after updating to verison 2.3.1. Did you happen to look at the log to see if it was still the same error?

Best regards,

Robin

To be honest i installed 2. 3.1 on a new computer running windows 7 x64 fully updated for a new user and printed a few PDF on the administrator profile an it worked. I created a non admin profile and gave the user the computer to use an she called me later on in the day an told me the PDF wasn’t printing, i open PDF creator an i saw the job waiting there. I immediately removed 2.3.1 and reverted to 2.2.2 and it worked.
I haven’t done any testing on the rest of users using old versions of PDF creator yet so i don’t know if things will be different for the rest of users, hopefully i will get a chance to try upgrade the rest when i have the time.

FINALLY i can now report that this issue was resolved in PDFCreator 2.3.2 … now I can smile again :laughing:

I will be rigorously testing version 2.4 before i roll it out to any of our clients to make sure there is no re-occurring issues.

Thanks for the hard work you guys put into this project, much appreciated! :+1: