"Owner Password" function not working properly

Dear Pdfforge,
I recently upgraded to the latest free version of your Pdfcreator software I’ve been using for a long time.
I’ve noticed that in v. 3+ (I’ve tested also the latest 3.12), if I set an “owner password” to protect my PDFs from being modified (also set cryptography to 128bit and disable all actions except from “print”) but I do not set an “user password” to open the file, I am still able to copy-paste the contents of the file. I use SumatraPDF as viewer.
If I set both passwords, the protection works properly.
The feature worked properly in older versions of your software.
Running on Win10 (updated) 64bit.

Any suggestion? I’m stuck.



I tried to reproduce this here but it still seems to be working as intended, I wasn’t able to reproduce the issue you describe. A lot of the checkboxes in the current PDFCreator encryption options are for allowing specific features, while they might have used to disable them, please check if the settings are really as intended.
In general, as long as you don’t set a password for opening the file, the viewing application can simply ignore any security restrictions, as technically they are only “suggestions” in the PDF format definition.
The current version of Sumatra detects the restriction and therefore will not allow to copy the text directly, but it does automatically copy an image of the text instead, so basic copy and paste might still work.

Best regards


I think I managed to get it working: I used to check the option “use a password to open the file…” (roughly translated to english) at the very top of the window, but only se the owner password and no user password.
By unchecking that option, the dialog box that opens up to set the passwords only displays one textbox for the owner password. Doing this makes the protection effective as intended.
Thank you for the support.