Page orientation problem in PDF Creator

Dear forum,

I have a page orientation problem in Creator. I made PDF export from MS Excel but the files became quite large due to embedded truetype fonts, so I decided to print them to pdf with Creator. The pages are landscape oriented, and when I created them with Excel, they’re made with the following metadata:

PageMediaNumber: 1
PageMediaRotation: 0
PageMediaRect: 0 0 841.68 595.2
PageMediaDimensions: 841.68 595.2

PDF Creator make the file with this metadata:

PageMediaNumber: 1
PageMediaRotation: 90
PageMediaRect: 0 0 595 842
PageMediaDimensions: 595 842

The results are the same on screen and paper but it seems that Creator make a double rotation, and this causes my problem: I want to digitally sign this file with an embedded logo, and due to this rotation the signer program aligns the logo badly, rotated by 90 degree (unfortunately I cannot modify the signer program).

Is there a method to directly set this page orientation in Pdf Creator, or make it correct any other ways?

Thank you for your kind help in advance!



by default the page orientation is detected automatically in PDFCreator, which doesn’t always work perfectly.
You can change this setting under profile settings->PDF, but I am not sure if manually setting the orientation to landscape or portrait will solve the problem.

Best regards,


Hi Robin,

Thank you for your fast reply! I tried these settings, but I can set page rotation only in PDF settings (none, all, single page), but I cannot set default page orientation anywhere (or I haven’t found it). I can set standard or custom page sizes (A4 f.e.), but it didn’t help either. As I see without page rotation the orientation is portrait initially and the page content is rotated 90 degr. (on paper it is OK, but the logo was put on the wrong place)

Best regards,