PDF architect 4 windows 10 installation error


i have recently purchased PDF Architect 4 professional but i’m not able to install it under windows 10 home 64 bit. When i lunch the installation process it stops immediately because it tries to install the main app and all the packages on a mapped drive P: and not in C: like it should…I tried to delete all the mapped drives, then rebooted the pc, but everytime i keep getting the same error (invalid drive P:).

What can i do about it? :confused: Many thanks

PS: poor english, sorry :stuck_out_tongue:


if you go to the advanced settings in the setup, you can specify the path where it gets installed.
I honestly don’t know why it is trying to install onto drive P:\, we have never heard of this issue before.

best regards,

Robin, we’ve had PDF Architect 4 installed on Windows 7 in our office for quite a while. We just recently upgraded to Windows 10 and PDF Architect seemd to work just fine…UNTIL…we received a notice to upgrade. It keeps failing the upgrade so I uninstalled the program completely from one of our Windows 10 machines and tried to reinstall. We then got the very same issue as Ayoffa stated in his post.

I attempted your recommended fix but the C:\Program Files\ location was already in the destination installation section. The problem still occurred and when I checked the error message, it gave the exact same thing…trying to install to P:\ drive.

Since this is happening on all of our Windows 10 computers, it appears there is a bug in the installation file and most likely in the upgrade file as well. Let me know of any other workaround.



are you using Windows 10 home or pro?
Which version of the installer are you using?
I wasn’t able to reproduce this error on a Win 10 Pro VM.
If you like you could try using the MSI instead until we have been able to reproduce/fix this issue.

Best regards,