PDF Architect 7 not installing


#1

I purchased ver 7 about an hour ago and not able to install at all. I have ver 5 but I have now uninstalled this as I thought it may have been causing the error. but still not possible. I downloaded the installer from the invoice link and also from the website link after completing the purchase. Each time I receive the following message. "PDF Architect installation process was interrupted. Signature is invalid". I have sent message to live chat, to help, and contact us and no one is around to help.


#2

Hi,

sorry for the trouble.
The PDF Architect Support is located in Canada where it currently is 6am, so it might take a few more hours until you get a response from them.
Since I am part of the PDFCreator Team, I can only offer limited support on this issue.
I downloaded and ran the installer from https://download.pdfforge.org/download/pdfarchitect7/PDFArchitect-stable without any errors, have you checked that nothing on your end is interfering with the download?

Best regards

Robin


#3

Thank you so much Robin, this worked and as soon as I logged onto the account it switched me to the purchased version. huge thanks


#4

Glad I was able to help.