PDF Architect Freezes after creating PDF

 With the additon of PDF Architect from previous versions of PDFCreator, my computer will constantly hang for a good 2 minutes while it opens up the architect.  Is there any way to fix this or disable architect all together as I don't want to use it?  thanks.


Windows 7, 8GB RAM


sorry for the inconvinience, this is very odd and I havn´t been able to reproduce this behaviour on the test machine.
On the Windows 7 machine, is it only the options from the “options window” that don´t work, or don´t any of the options get saved at all?





if the Architect still runs even though you disabled "Edit with PDFArchitect",and you still have enabled "After auto saving open with default program", then PDFArchitect is set as default for opening PDFs. You can change this in your windows control panel or simply by right clicking on any PDF and choosing "open with...".





You can "disable" PDF Architect. After you'll decide to print something with PDF Creator you should see windows with optiona e.g. for document names. At the bottom of this window (but above buttons "Cancel", "Save"...)  you can find options woth two check marks. Disable second named "Edit PDF files with PDFArchitect" and Archtect will not start after printing PDF. If you disable first then PDF viewer (e.g. Acrobat Reader) will not start after printing.

PDF Architect has some problem because it can't work with PDF made by PDF Creator 1.5.0 (not only just after "printing") while it works with "older" PDFs.

Hmm... strange. PDF Creator doesn't remember setting within "printing window" when using it under Windows 7 (32-bit Ultimate) while under WinXP SP3 works correct. Even "3-times" reminder about option with editing in PDF Architect doesn't remember and with every printing I can see "this note will be shown 3 more times". I've got UAC enabled but I tried to run PDF Creator with "administrator privileges" buy no go. Except one thing - when I've printed test pages without closing "option window" then counter dropped to 0 (note disappeared) and removed check mark was remembered... until next run of "option window" or normal print job (regardless of "admin/no-admin privileges").

BTW This message editor is... "different". By default it disables spell checking (in my SeaMonkey 2.12) and I can't edit my post to e.g. correct them. I can't see option for posting "a code" nor "spoiler" to not make big mess in my message.

OK! I've been able to fix it (PDF Architect "run" issue) by changing registry settings:

HKCU\\Software\\PDFCreator\\Program -> EditWithPDFArchitect -> 0

This parameter is present (on my Win7) at HKCU only.

Sorry but NO. Printed PDF was opened in background with Adobe Acrobat while PDFArchitect was freezing. Like I wrote above printing PDFs during “one session of option’s settings” make it working correct… until option’s window was closed. All that under Win7 32-bit with UAC set default. Under WinXP SP3 works correct (i.e. remembers settings).

Sorry for delay (this new forum isn’t… user friendly). Settings within “main options” works correct i.e. are remembered. Only this “pop-up” window while printing have some problem.

Few moments ago I’ve noticed another glitch - when I tried to print large document and I canceled preparation (there was a bar with info how many pages were “processes”) then I saw that “pop-up” window… with option “Edit PDF files with PDF Architect” marked on (sic!). After this I tried to make “normal print” and mentioned option wasn’t marked. Win 7 32-bit…

pdf architect can open pdf files , i googled and found more info about pdf creating and printing. check here:  http://www.rasteredge.com/how-to/vb-net-imaging/pdf-creating/