PDF Creator doesn't work after upgrade to latest version


#1

PDF Creator has always worked great -- until this morning. I was asked if I wanted to upgrade and did. Now the best I get is a document in the "queue" then NOTHING. HELP! How would I get rid of everything and start over. Doesn't show up in programs, only printers. Does removing from "Printers" get rid of everything for a clean re-install? Went from 3.4.0 to 3.4.1 and now I'm stuck! Noticed that pdfcmon.dll doesn't seen to be anywhere in the system.


#2

Hi @printman,

Are you able to use the setup from our website to uninstall PDFCreator?

There is a guide that shows you how to reinstall PDFCreator: https://support.pdfforge.org/article/42-pdfcreator-reinstallation


#3

I did everything you mentioned on the website and -- NO Difference. Nothing to uninstall listed under programs. Removed printer from Printers. Searched and deleted everything I could find on the whole drive C except for a very few files the system wouldn't allow me to. The pdfmon.dll wasn't in System 32 either before, during, or after the process. I re-installed 3.4.1 and a "print" gets only as far as in the queue. Still stuck! Incidentally, even after my removing everything I could find, when I went to re-install the process reported that another version needed to be de-installed!


#4

Could you create a trace log (https://support.pdfforge.org/article/80-how-to-create-a-trace-log) and send it over via email (https://support.pdfforge.org/contact)?


#5

Great idea -- but there is no pdfcreator to start! The program is not listed among the installed programs The only thing that comes up when I type in pdfcreator is the install file. But when I run it it says there is an installed version that must be un-installed. STILL STUCK.


#6

Hi,

please try running the setup with the /FORCEINSTALL parameter as described here
This should run the setup in any case even if remainders of a previous installation are found.

Best regards

Robin


#7

I did that without closing anything and the result was the same. I re-booted and on a whim stopped my anti-virus program (Vipre) and then did it from a command line with administrator privilege. FINALLY, it installed. Never had to do anything like that before -- including stopping Vipre. Onward and upward.


#8

Maybe I spoke too soon! Dramatically different from every past version. The only way I could get anything to "print" was to first open the document (Word, for example), print, then -- nothing -- until I opened the PDFCreator program, THEN the usual dialogue opened up showing where it would be saved, etc. Why should I need to manually open the program itself just to get to that dialogue? Before, all I had to do was to print and it would open, etc. Now everything is seriously convoluted. I tried leaving PDFCreator open and THEN printing and -- NOTHING. The program has to be closed then manually opened to get the printing function to work.


#9

Hi,

sorry for the trouble; you shouldn't need to open the application manually, this is not the default behavior and as you say makes no sense most workflows. Most likely the pdfcmon.dll (our print monitor, which listens to the incoming print jobs and automatically starts PDFCreator when any job arrives) didn't get replaced properly during the update / installation. Probably the best attempt to get a clean, properly functional installation again is to uninstall, reboot and install again afterwards.
If this doesn't resolve all issues, please send the setuplog.txt (from inside the PDFCreator program folder) to our support and we will help you.

Best regards

Robin